Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353952 - [geo-rep]: rsync should not try to sync internal xattrs
Summary: [geo-rep]: rsync should not try to sync internal xattrs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Saravanakumar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1441574 1441576
TreeView+ depends on / blocked
 
Reported: 2016-07-08 13:52 UTC by Saravanakumar
Modified: 2017-05-30 18:34 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1327045
: 1441574 1441576 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:34:38 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-07-08 13:52:49 UTC
REVIEW: http://review.gluster.org/14880 (geo-rep: filter out xtime attribute during getxattr) posted (#1) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 2 Vijay Bellur 2016-07-18 11:16:15 UTC
REVIEW: http://review.gluster.org/14880 (geo-rep: filter out xtime attribute during getxattr) posted (#2) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 3 Vijay Bellur 2016-07-21 11:20:00 UTC
REVIEW: http://review.gluster.org/14880 (geo-rep: filter out xtime attribute during getxattr) posted (#3) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 4 Vijay Bellur 2016-07-27 05:17:11 UTC
REVIEW: http://review.gluster.org/14880 (geo-rep: filter out xtime attribute during getxattr) posted (#4) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 5 Vijay Bellur 2016-07-27 09:03:13 UTC
REVIEW: http://review.gluster.org/14880 (geo-rep: filter out xtime attribute during getxattr) posted (#5) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 6 Worker Ant 2017-04-03 09:02:44 UTC
REVIEW: https://review.gluster.org/14880 (geo-rep: filter out xtime attribute during getxattr) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 7 Worker Ant 2017-04-03 15:14:57 UTC
REVIEW: https://review.gluster.org/14880 (geo-rep: filter out xtime attribute during getxattr) posted (#7) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 8 Worker Ant 2017-04-07 10:36:45 UTC
REVIEW: https://review.gluster.org/14880 (geo-rep: filter out xtime attribute during getxattr) posted (#8) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 9 Worker Ant 2017-04-11 09:15:03 UTC
COMMIT: https://review.gluster.org/14880 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit fddf202af078f09cf443fe76f8f43ad8eda2b4b6
Author: Saravanakumar Arumugam <sarumuga@redhat.com>
Date:   Fri Jul 8 19:10:45 2016 +0530

    geo-rep: filter out xtime attribute during getxattr
    
    georep gsyncd's xtime needs to filtered irrespective
    of any process access.
    
    This way, we can avoid (unnecessarily)syncing xtime attribute
    to slave, which may raise permission denied errors.
    
    test case modified to check for xtime xattr only in backend.
    
    Change-Id: I2390b703048d5cc747d91fa2ae884dc55de58669
    BUG: 1353952
    Signed-off-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: https://review.gluster.org/14880
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Tested-by: Kotresh HR <khiremat@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 10 Shyamsundar 2017-05-30 18:34:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.