Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353949 - Satellite 6 installer does not force changes to sudoers file for foreman-proxy user.
Summary: Satellite 6 installer does not force changes to sudoers file for foreman-prox...
Keywords:
Status: CLOSED DUPLICATE of bug 1348616
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.1.9
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 13:44 UTC by Calvin Hartwell
Modified: 2016-08-23 16:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 16:17:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Calvin Hartwell 2016-07-08 13:44:13 UTC
Description of problem:

The customer's regular RHEL6/7 build sets the permissions on the sudoers file to read only. Their sudoers file also does not include the directive to import files from the /etc/sudoers.d/ folder (specifically, foreman-proxy config file which is generated by Satellite): #includedir /etc/sudoers.d

This issue was encountered not only by the katello-installer but also by the capsule-installer. May also be present in the new foreman-installer in satellite 6.2.

Found on the capsule through this issue: https://access.redhat.com/solutions/1399283

Version-Release number of selected component (if applicable):

6.1.X
6.1.9
 
Maybe 6.2.0

How reproducible:

Easy to reproduce. 

Steps to Reproduce:
1.  Setup server for satellite install, enable repos, firewall ports, partitions etc. 

2. Remove include directive in the suoders file (#includedir /etc/sudoers.d in /etc/sudoers)

3. Remove write permissions on sudoers file for root (or any user)

4. Run capsule installer or katello installer. 

5. Hit random errors later on when sudo privs are required by foreman-proxy user (like when publishing content views or getting the ca certs from a capsule)

Actual results:

sudo privs for foreman-proxy user are wrong because installer has not configured them correctly. 

Expected results:

Satellite installer should set its required permissions correctly. It should ensure the include directive is inside the sudoers file. 

Additional info:

Related to solving customer case 01655663

Comment 2 Stephen Benjamin 2016-08-23 16:17:19 UTC

*** This bug has been marked as a duplicate of bug 1348616 ***


Note You need to log in before you can comment on or make changes to this bug.