Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353941 - typo in help output
Summary: typo in help output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sg3_utils
Version: 7.4
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks: 1356614
TreeView+ depends on / blocked
 
Reported: 2016-07-08 13:23 UTC by George Angelopoulos
Modified: 2017-05-11 12:49 UTC (History)
1 user (show)

Fixed In Version: sg3_utils-1.37-8.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1356614 (view as bug list)
Environment:
Last Closed: 2016-11-04 02:54:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2296 normal SHIPPED_LIVE sg3_utils bug fix update 2016-11-03 13:38:32 UTC

Description George Angelopoulos 2016-07-08 13:23:30 UTC
Description of problem:
Typo.

Version-Release number of selected component (if applicable):
# rpm -q sg3_utils
sg3_utils-1.37-5.el7.x86_64


How reproducible:
consistently

Actual results:
# scsi-rescan -h | grep '0 is not found'
--nooptscan:     don't stop looking for LUNs is 0 is not found
                                             ^^

Expected results:
# scsi-rescan -h | grep '0 is not found'
--nooptscan:     don't stop looking for LUNs if 0 is not found
                                             ^^

Comment 2 Ondrej Vasik 2016-07-09 06:14:50 UTC
Typo is in manpage as well. https://github.com/hreinecke/sg3_utils seems to be current upstream git repo.

Comment 4 George Angelopoulos 2016-07-09 09:48:00 UTC
(In reply to Ondrej Vasik from comment #2)
> Typo is in manpage as well. https://github.com/hreinecke/sg3_utils seems to
> be current upstream git repo.

The homepage of the project is this:

http://sg.danny.cz/sg/sg3_utils.html

If you scroll to the bottom it says they are using subversion and the git repos are mirrors maintained by contributors. Still, you can try opening a GitHub issue.

The author of sg3_utils appears to be Douglas Gilbert (dgilbert at  interlog dot com) based on this page [1] and the git mirror log.

[1] http://sg.danny.cz/sg/

Comment 5 Ondrej Vasik 2016-07-10 21:52:50 UTC
danny.cz is domain of former Fedora maintainer - Dan Horak - who maintained the package before David - and github mentioned by me is there mentioned as git mirror of upstream svn. So yes, I think pull request there is the right way... as I don't see any better contact.

Comment 10 errata-xmlrpc 2016-11-04 02:54:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2296.html


Note You need to log in before you can comment on or make changes to this bug.