Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353921 - pyrpkg-1.45 regression: 'fedpkg retire' now fails
Summary: pyrpkg-1.45 regression: 'fedpkg retire' now fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpkg
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: cqi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 12:15 UTC by Rex Dieter
Modified: 2016-08-03 02:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-03 02:39:08 UTC


Attachments (Terms of Use)

Description Rex Dieter 2016-07-08 12:15:05 UTC
'fedpkg retire' fails:
deletes .spec, adds dead.package... then gives new error: 
Could not retire package: No spec file found. This package is retired.

Trying to manually push (fedpkg push), gives similar error: 
Could not execute push: No spec file found. This package is retired.

Comment 1 Rex Dieter 2016-07-08 12:16:23 UTC
applies to both f23/f24, but since the f24 update already went stable...

Comment 2 cqi 2016-07-08 12:48:56 UTC
Hi Rex, thanks for reporting this bug. A workaround might be just a git-push. Could you have a try? This bug will be fixed soon.

Comment 3 cqi 2016-07-08 12:51:42 UTC
Code checking missing patches in pyrpkg.Commands.push blocks push command when retire. Meanwhile, test_retire should be modified to test whole retire process including push, that is currently mocked.

Comment 4 cqi 2016-07-12 02:58:47 UTC
Related to https://pagure.io/rpkg/issue/71

Comment 5 Stephen Gallagher 2016-07-20 14:51:51 UTC
Can we get an updated build to fix this please?

Comment 6 cqi 2016-07-21 01:19:33 UTC
(In reply to Stephen Gallagher from comment #5)
> Can we get an updated build to fix this please?

The fix is included in latest version 1.46-1, that is in testing phase now in Bodhi[1]. Could you try the new version and help to test it?

[1] https://bodhi.fedoraproject.org/updates/?packages=rpkg

Comment 7 cqi 2016-08-03 02:39:08 UTC
Package is available in F23 now.


Note You need to log in before you can comment on or make changes to this bug.