Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353899 - ipa-advise: object of type 'type' has no len()
Summary: ipa-advise: object of type 'type' has no len()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 11:16 UTC by Sudhir Menon
Modified: 2016-11-04 05:56 UTC (History)
2 users (show)

Fixed In Version: ipa-4.4.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:56:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-07-08 11:16:53 UTC
Description of problem: ipa-advise without any advise displays 'object of type 'type' has no len()'

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:Always


Steps to Reproduce:
1. Install ipa-server
2. run ipa-advise command

Actual results:
[root@server ~]# ipa-advise 
----------------------------------------------------------------------
List of available advices
----------------------------------------------------------------------
object of type 'type' has no len()
The ipa-advise command failed.

Expected results:
Although there are no advisories for customers right now for this release the command should display proper message instead of displaying that the command failed.

Additional info:

Comment 2 Petr Vobornik 2016-07-08 12:03:00 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6044

Comment 3 Petr Vobornik 2016-07-12 09:04:06 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/c1d8629b7490f443eededf0c0d0472d8285f85e8

Comment 5 Sudhir Menon 2016-07-15 12:55:58 UTC
Fix is seen.
Verified using ipa-server-4.4.0-2.1.el7.x86_64

[root@server ~]# ipa-advise 
----------------------------------------------------------------------
List of available advices
----------------------------------------------------------------------
config-fedora-authconfig             : Authconfig instructions for
                                       configuring Fedora 18/19 client with
                                       IPA server without use of SSSD.
config-freebsd-nss-pam-ldapd         : Instructions for configuring a
                                       FreeBSD system with nss-pam-ldapd.
config-generic-linux-nss-pam-ldapd   : Instructions for configuring a system
                                       with nss-pam-ldapd. This set of
                                       instructions is targeted for linux
                                       systems that do not include the
                                       authconfig utility.
config-generic-linux-sssd-before-1-9 : Instructions for configuring a system
                                       with an old version of SSSD (1.5-1.8)
                                       as a IPA client. This set of
                                       instructions is targeted for linux
                                       systems that do not include the
                                       authconfig utility.
config-redhat-nss-ldap               : Instructions for configuring a system
                                       with nss-ldap as a IPA client. This
                                       set of instructions is targeted for
                                       platforms that include the authconfig
                                       utility, which are all Red Hat based
                                       platforms.
config-redhat-nss-pam-ldapd          : Instructions for configuring a system
                                       with nss-pam-ldapd as a IPA client.
                                       This set of instructions is targeted
                                       for platforms that include the
                                       authconfig utility, which are all Red
                                       Hat based platforms.
config-redhat-sssd-before-1-9        : Instructions for configuring a system
                                       with an old version of SSSD (1.5-1.8)
                                       as a IPA client. This set of
                                       instructions is targeted for
                                       platforms that include the authconfig
                                       utility, which are all Red Hat based
                                       platforms.

Comment 7 errata-xmlrpc 2016-11-04 05:56:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.