Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353897 - storage profiles not working
Summary: storage profiles not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 2
Assignee: Nishanth Thomas
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On: 1349786
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-07-08 11:15 UTC by Lubos Trilety
Modified: 2016-08-23 19:56 UTC (History)
2 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:56:22 UTC


Attachments (Terms of Use)
crush map (deleted)
2016-07-08 11:15 UTC, Lubos Trilety
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC
Gerrithub.io 283870 None None None 2016-07-13 18:38:33 UTC
Red Hat Bugzilla 1354603 None None None Never

Internal Links: 1354603

Description Lubos Trilety 2016-07-08 11:15:19 UTC
Created attachment 1177616 [details]
crush map

Description of problem:
It is possible to use and/or create storage profiles, however a crush map is not created correctly hence those rules are not really present in ceph.
# ceph osd crush rule ls
[
    "replicated_ruleset"
]
Moreover because UI uses its storage profiles (crush rules) that could cause that pools cannot be created.

Version-Release number of selected component (if applicable):
rhscon-ui-0.0.45-1.el7scon.noarch
rhscon-core-selinux-0.0.31-1.el7scon.noarch
rhscon-ceph-0.0.30-1.el7scon.x86_64
rhscon-core-0.0.31-1.el7scon.x86_64

How reproducible:
100%

Steps to Reproduce:
1. During creating of a cluster add some storage profiles (e.g. ec_profile)
2. Check crush map
3.

Actual results:
crush map does not have any crush rule corresponding to created storage profiles
There are these lines in log:
ec_profile In cleared 0 0 {0 0 0 }} not found in cluster, removing from DB
general In cleared 0 0 {0 0 0 }} not found in cluster, removing from DB

Expected results:
storage profiles and corresponding rules are created correctly

Additional info:
see crush map in attachment

Comment 2 Lubos Trilety 2016-07-22 08:42:45 UTC
Tested on:
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-ui-0.0.48-1.el7scon.noarch
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64

# ceph osd crush rule ls
[
    "replicated_ruleset",
    "test"
]

Crush map checked.

Comment 4 errata-xmlrpc 2016-08-23 19:56:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.