Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353896 - [RFE][Rebrand]Change info in /etc/os-release from RHEVH-NG to RHVH
Summary: [RFE][Rebrand]Change info in /etc/os-release from RHEVH-NG to RHVH
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.0.1
: 4.0.0
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
: 1353891 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 11:13 UTC by Ying Cui
Modified: 2016-08-23 21:12 UTC (History)
8 users (show)

Fixed In Version: redhat-release-virtualization-host-4.0-0.16.el7
Doc Type: If docs needed, set a value
Doc Text:
Starting 4.0 Red Hat Enterprise Virtualization Hypervisor (RHEV-H) becomes Red Hat Virtualization Host (RHVH), and will be identified as such.
Clone Of:
Environment:
Last Closed: 2016-08-23 21:12:30 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1688 normal SHIPPED_LIVE redhat-release-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:37:04 UTC

Description Ying Cui 2016-07-08 11:13:33 UTC
Description of problem:
For rebranding, we need to change Name, VARIANT, PRETTY_NAME, CPE_NAME in /etc/os-release from "Red Hat Enterprise Virtualization Hypervisor NG 4.0" to "Red Hat Virtualization Host"

Comment 1 Ryan Barry 2016-07-08 14:22:43 UTC
*** Bug 1353891 has been marked as a duplicate of this bug. ***

Comment 4 Ying Cui 2016-07-11 08:19:40 UTC
Incompletely fix, it still display "Red Hat Virtualization Hypervisor" in /etc/os-release, for expectation, it should display "Red Hat Virtualization Host"

# rpm -qa redhat-release-virtualization-host
redhat-release-virtualization-host-4.0-0.13.el7.x86_64

# cat /etc/os-release 
NAME="Red Hat Enterprise Linux"
VERSION="7.2"
VERSION_ID="7.2"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Virtualization Hypervisor"
VARIANT_ID="ovirt-node"
PRETTY_NAME="Employee SKU"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:beta:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Red Hat Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.2

Comment 5 Ryan Barry 2016-07-11 12:14:01 UTC
Hey Ying --

I think this will take a small discussion, since the intended package rename does not match the branding rename.

We're following the package naming scheme provided, but the documentation clearly still indicates RHV-H as "Hypervisor", not "Host", which is why the PRETTYNAME follows that scheme.

Since we're following the docs, I'd suggest that we move this bug to VERIFIED, and open a bug to track whether the naming (redhat-virtualization-host, redhat-release-virtualization-host) is appropriate, targeted for 4.1 or 4.0 GA, since that change is much less visible.

Comment 6 Ryan Barry 2016-07-11 13:45:01 UTC
Moran, Yaniv, Bronce, Scott, thoughts on package naming/visible naming?

Comment 7 Ryan Barry 2016-07-12 16:20:34 UTC
Ok, sherold has confirmed that it should be "Host".

Comment 8 Ying Cui 2016-07-14 10:55:53 UTC
VERIFIED the bug on RHVH-7.2-20160713.0-RHVH-x86_64-dvd1.iso

# rpm -qa redhat-release-virtualization-host
redhat-release-virtualization-host-4.0-0.18.el7.x86_64

# cat /etc/os-release 
NAME="Red Hat Enterprise Linux"
VERSION="7.2"
VERSION_ID="7.2"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Virtualization Host"
VARIANT_ID="ovirt-node"
PRETTY_NAME="Red Hat Virtualization Host 4.0"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:beta:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Red Hat Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.2

For above,  I will open another new issue on CPE_NAME, 

and I will confirm with devel the rpm name should be redhat-release-virtualization-host or redhat-virtualization-host although it is not functional impact. 

See comment 7, no other needinfo need.

Comment 10 errata-xmlrpc 2016-08-23 21:12:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1688.html


Note You need to log in before you can comment on or make changes to this bug.