Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353895 - ipa-replica-install lacks interactive mode
Summary: ipa-replica-install lacks interactive mode
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
: 1376027 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 11:09 UTC by Abhijeet Kasurde
Modified: 2019-01-31 14:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 14:32:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
ipa-replica-install.log (deleted)
2016-07-08 11:14 UTC, Abhijeet Kasurde
no flags Details
ipa-client-install.log (deleted)
2016-07-08 12:51 UTC, Abhijeet Kasurde
no flags Details
ipa-replica-install.log (deleted)
2016-07-08 12:51 UTC, Abhijeet Kasurde
no flags Details

Description Abhijeet Kasurde 2016-07-08 11:09:54 UTC
Description of problem:
If user triggers ipa-replica-install, commands starts without required parameters and fails.


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Trigger ipa-replica-install on replica server without parameters and without ipa-client-install 

Actual results:
Fails to install replica on given machine due to lack of required parameters.

Expected results:
Command should detect and enter in interactive mode for user input.

Comment 1 Abhijeet Kasurde 2016-07-08 11:14:41 UTC
Created attachment 1177615 [details]
ipa-replica-install.log

Comment 3 Petr Vobornik 2016-07-08 12:09:42 UTC
What was in the console output and ipaclient-install.log?

Error:
"""
Fails to install replica on given machine due to lack of required parameters.
"""

is very general so I wonder if the complete message was understandable, i.e. admin can know what is missing.

Comment 4 Abhijeet Kasurde 2016-07-08 12:50:32 UTC
Console output for 

# ipa-replica-install 
Configuring client side components
WARNING: ntpd time&date synchronization service will not be configured as
conflicting service (chronyd) is enabled
Use --force-ntpd option to disable it and force configuration of ntpd

One of password / principal / keytab is required.
Installation failed. Rolling back changes.
IPA client is not configured on this system.
Removing client side components
IPA client is not configured on this system.

ipa.ipapython.install.cli.install_tool(Replica): ERROR    Configuration of client side components failed!
ipa.ipapython.install.cli.install_tool(Replica): ERROR    The ipa-replica-install command failed. See /var/log/ipareplica-install.log for more information


Attaching replica-install and client-install logs.

Comment 5 Abhijeet Kasurde 2016-07-08 12:51:00 UTC
Created attachment 1177681 [details]
ipa-client-install.log

Comment 6 Abhijeet Kasurde 2016-07-08 12:51:33 UTC
Created attachment 1177682 [details]
ipa-replica-install.log

Comment 7 Petr Vobornik 2016-07-12 16:13:57 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6068

Comment 9 Petr Vobornik 2016-09-23 15:55:23 UTC
*** Bug 1376027 has been marked as a duplicate of this bug. ***

Comment 11 Petr Vobornik 2017-10-16 11:49:01 UTC
For upcoming months or more the FreeIPA/IdM team is focusing on stability, testability of FreeIPA/IdM and thus postponing any RFEs or non-critical bugs.

Comment 12 Rob Crittenden 2019-01-31 14:32:24 UTC
Thank you taking your time and submitting this request for Red Hat Enterprise Linux. The request was cloned to the upstream tracker a long time ago (see link to the upstream ticket above), but it was unfortunately not given priority either in the upstream project, nor in Red Hat Enterprise Linux.

Given that this request is not planned for a close release, it is highly unlikely it will be fixed in this major version of Red Hat Enterprise Linux. We are therefore closing the request as WONTFIX.

To request that Red Hat reconsiders the decision, please reopen the Bugzilla with the help of Red Hat Customer Service and provide additional business and/or technical details about it's importance to you. Please note that you can still track this request or even offer help in the referred upstream Pagure ticket to expedite the solution.


Note You need to log in before you can comment on or make changes to this bug.