Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353892 - arandr-0.1.7.1-6.fc24.noarch: xrandr.py:42:__init__:Exception: XRandR 1.2/1.3 required.
Summary: arandr-0.1.7.1-6.fc24.noarch: xrandr.py:42:__init__:Exception: XRandR 1.2/1.3...
Keywords:
Status: CLOSED DUPLICATE of bug 1349006
Alias: None
Product: Fedora
Classification: Fedora
Component: arandr
Version: 24
Hardware: noarch
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Maros Zatko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 11:03 UTC by Peter Ludikovsky
Modified: 2016-07-11 02:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-11 02:25:39 UTC


Attachments (Terms of Use)

Description Peter Ludikovsky 2016-07-08 11:03:19 UTC
Description of problem:
Starting arandr 0.1.7.1-6.fc24 results in an exception:

Traceback (most recent call last):
  File "/usr/bin/arandr", line 42, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/screenlayout/gui.py", line 318, in main
    force_version=options.force_version
  File "/usr/lib/python2.7/site-packages/screenlayout/gui.py", line 157, in __init__
    self.widget = widget.ARandRWidget(display=randr_display, force_version=force_version)
  File "/usr/lib/python2.7/site-packages/screenlayout/widget.py", line 48, in __init__
    self._xrandr = XRandR(display=display, force_version=force_version)
  File "/usr/lib/python2.7/site-packages/screenlayout/xrandr.py", line 42, in __init__
    raise Exception("XRandR 1.2/1.3 required.")
Exception: XRandR 1.2/1.3 required.


Version-Release number of selected component (if applicable):
0.1.7.1-6.fc24

How reproducible:
Always

Steps to Reproduce:
1. install arandr and xrandr
2. run arandr

Actual results:
Exception

Expected results:
Arandr starting

Additional info:
Tried to report it through abrt, but was added to bug #922336, which describes a similar issue for FC18.

Comment 1 Wei-Lun Chao 2016-07-11 02:25:39 UTC

*** This bug has been marked as a duplicate of bug 1349006 ***


Note You need to log in before you can comment on or make changes to this bug.