Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353890 - Hovering over icons - inconsistent color
Summary: Hovering over icons - inconsistent color
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine-dashboard
Classification: oVirt
Component: Core
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Scott Dickerson
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 10:59 UTC by Pavel Stehlik
Modified: 2017-08-29 09:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-29 09:33:11 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+
mgoldboi: planning_ack+
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
dash-icons-colors.mov (deleted)
2016-07-08 10:59 UTC, Pavel Stehlik
no flags Details

Description Pavel Stehlik 2016-07-08 10:59:09 UTC
Created attachment 1177614 [details]
dash-icons-colors.mov

Description of problem:
 There is difference when you hover over 'Hosts' 'Events' numbers. Once mouse is over - the color is blue incl. some {not all} icons. Eg Events - Bell icon changes color to blue (from black), but 'Critical' red icon stays always red. 
See att movie.

Version-Release number of selected component (if applicable):
beta1-4.0
FF 47.0


How reproducible:
100%

Steps to Reproduce:
1. have some critical events & hover over the number in dashboard
2.
3.

Actual results:
Some icons change color, some don't.

Expected results:
Consistent behaviour (either not changing color or changing on all icons in the line).

Additional info:

Comment 1 Greg Sheremeta 2016-07-19 15:22:37 UTC
In your example, Storage Domains and VMs are both "0", so those aren't changing on hover by design. There's nothing to click.

@Serena, on hover, "Events - Bell icon changes color to blue (from black), but 'Critical' red icon stays always red. See att movie." Is this a bug or a feature?

Comment 2 Serena 2016-07-19 16:45:21 UTC
@Greg, currently in the PatternFly design documentation and code snippets, the icon does not change color upon hover. 

I will say that the PatternFly did some testing at RH Summit on this fact, but I'm trying to find out if the analysis has been done, and if there are any recommendations to change this behavior.  I should get an answer soon and will respond back with an update.

Comment 5 Scott Dickerson 2017-01-13 19:34:05 UTC
Update:  I brought this issue up with the PatternFly team.  They're discussing it internally and will be user testing various options.  Once they complete the analysis, I'll have a way forward to solve this bug.

Comment 6 Oved Ourfali 2017-08-29 09:33:11 UTC
Doesn't sound important enough to prioritize.
Closing as wontfix.


Note You need to log in before you can comment on or make changes to this bug.