Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353888 - Fix the help for ipa otp and other topics
Summary: Fix the help for ipa otp and other topics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 10:53 UTC by Sudhir Menon
Modified: 2016-11-04 05:56 UTC (History)
5 users (show)

Fixed In Version: ipa-4.4.0-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:56:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-07-08 10:53:01 UTC
Description of problem: Fix the help for ipa otp


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:Always


Steps to Reproduce:
1. Check the help for otp commands

Actual results:
[root@server ipa-host-cli]# ipa otp
  otptoken-yubikey  YubiKey Tokens
ipa: ERROR: unknown command 'otp'

[root@server ipa-host-cli]# ipa otpconfig
  otpconfig  OTP configuration
ipa: ERROR: unknown command 'otpconfig'

[root@server ipa-host-cli]# ipa otptoken
  otptoken  OTP Tokens
ipa: ERROR: unknown command 'otptoken'

Expected results:
Fix the help for otp.

Additional info:

Comment 1 Sudhir Menon 2016-07-08 11:05:11 UTC
[root@server ~]# ipa
Error: Command not specified

[root@server]# ipa automember
ipa: ERROR: unknown command 'automember'

[root@server]# ipa automount
ipa: ERROR: unknown command 'automount'

[root@server ~]# ipa ca
ipa: ERROR: unknown command 'ca'

[root@server ~]# ipa caacl
ipa: ERROR: unknown command 'caacl'

[root@server ~]# ipa cert 
ipa: ERROR: unknown command 'cert'

[root@server ~]# ipa certprofile
ipa: ERROR: unknown command 'certprofile'

[root@server ~]# ipa config
ipa: ERROR: unknown command 'config'

[root@server ~]# ipa delegation
ipa: ERROR: unknown command 'delegation'

[root@server ~]# ipa dns
ipa: ERROR: unknown command 'dns'

[root@server ~]# ipa dnsserver
ipa: ERROR: unknown command 'dnsserver'

[root@server ~]# ipa domainlevel
ipa: ERROR: unknown command 'domainlevel'

[root@server ~]# ipa vault
ipa: ERROR: unknown command 'vault'

[root@server ~]# ipa user
ipa: ERROR: unknown command 'user'

[root@server ~]# ipa trust
ipa: ERROR: unknown command 'trust'

[root@server ~]# ipa topology
ipa: ERROR: unknown command 'topology'

[root@server ~]# ipa group
ipa: ERROR: unknown command 'group'

Comment 3 Petr Vobornik 2016-07-08 12:12:34 UTC
correct usage is:
   ipa help topics
   ipa help user
   
output:
"""
$ ipa group
ipa: ERROR: unknown command 'group'
"""

is actually correct.

The bug should be returned to its original state:
   ipa help otp
   ipa help otptoken
   ipa help otpconfig

don't return all expected commands.

Comment 4 Rob Crittenden 2016-07-08 12:40:43 UTC
In at least 4.2 this would print the help out before displaying the unknown command error, I think that is what he is reporting. One could argue that the previous behavior was a bug.

Comment 5 Sudhir Menon 2016-07-08 12:56:34 UTC
Rob,
Yes that is what i meant to say. And I also agree with Petr on how to run the command in correct way. i.e ipa help <commandname>

Comment 6 Petr Spacek 2016-07-12 10:53:22 UTC
The very same problem applies to topics 'hbac', 'dns' (which contains only subset of commands). I would use to fix all of them because the code change will (likely) be the very same.

Comment 7 Petr Vobornik 2016-07-12 16:14:42 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6069

Comment 8 Xiyang Dong 2016-07-13 19:14:54 UTC
(In reply to Petr Spacek from comment #6)
> The very same problem applies to topics 'hbac', 'dns' (which contains only
> subset of commands). I would use to fix all of them because the code change
> will (likely) be the very same.

'sudo' is also affected, please fix on that too, thanks!

Comment 9 Petr Vobornik 2016-07-15 12:04:17 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/92dea9b186611f7f1ba8aa5952b4cfdc363d75b8

Comment 11 Martin Bašti 2016-07-22 11:53:07 UTC
Additional fix

Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/34767ba25936700ba331fc5b7791ecd151083501

Comment 13 Sudhir Menon 2016-07-29 10:42:04 UTC
Fix is seen in ipa-server-4.4.0-4.el7.x86_64

Obseravtion:

1. When ipa help <commandname> is given, the help is displayed without any error.
2. When ipa <commandname> is given, the help is displayed which was not shown before.  Note the error will also be displayed along with the help

Comment 15 errata-xmlrpc 2016-11-04 05:56:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.