Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353883 - [Intsvc_public_275] deployer should actively modify the logging-deployer-template during upgrade due to its name change since 3.3.0
Summary: [Intsvc_public_275] deployer should actively modify the logging-deployer-temp...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 10:24 UTC by Xia Zhao
Modified: 2017-02-10 20:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 20:07:11 UTC


Attachments (Terms of Use)

Description Xia Zhao 2016-07-08 10:24:23 UTC
Problem description: 
While upgrading from 3.2.0 to 3.3.0, After running
$ oc create -f https://raw.githubusercontent.com/openshift/origin-aggregated-logging/master/deployer/deployer.yaml
to create missing templates ( according to doc https://github.com/openshift/origin-aggregated-logging/tree/master/deployer#create-missing-templates )

It's needed to modify this line
 image: ${IMAGE_PREFIX}logging-deployment:${IMAGE_VERSION}
into 
 image: ${IMAGE_PREFIX}logging-deployer:${IMAGE_VERSION}
by running :
$ oc edit template logging-deployer-template -o yaml

Otherwise the upgrade can not be performed since deployer image changed its name since 3.3.0.

Version-Release number of selected component (if applicable):
openshift3/logging-deployer    3.3.0    000cdaaa18ea
https://github.com/openshift/origin-aggregated-logging/tree/master/deployer#create-missing-templates

How reproducible:
Always

Steps to Reproduce:
Please refer to "Problem description"

Actual Result:


Expected Result:


Additional info:

Comment 1 Xia Zhao 2016-07-08 10:25:47 UTC
Or we can just doc this if this can't be implemented in deployer

Comment 2 Luke Meyer 2016-07-15 19:26:27 UTC
The deployer cannot usefully modify its own template as the wrong template could not create the deployer correctly to begin with. What should happen is that ansible puts the new template in place as part of the upgrade. We should ensure that this happens.

For QE testing, you can `oc apply -f https://raw.githubusercontent.com/openshift/origin-aggregated-logging/enterprise/deployer/deployer.yaml` to get the right template.

Comment 3 Xia Zhao 2016-07-27 02:19:05 UTC
Yes, I see this template was updated to using "deplyer" instead of "deployment":
https://github.com/openshift/origin-aggregated-logging/blob/enterprise/deployer/deployer.yaml
, so this issue can be closed now. Could you please help transfer it back to ON_QA?

Comment 5 Rich Megginson 2017-02-10 03:40:59 UTC
Jeff - I think this bug is WONTFIX since the deployer is going away with 3.5.

Comment 6 Jeff Cantrill 2017-02-10 20:07:11 UTC
Moving to Ansible in 3.5 and no longer relevant.


Note You need to log in before you can comment on or make changes to this bug.