Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353882 - VM info of RHVH can't be shown on cockpit UI via Internet Explorer 11
Summary: VM info of RHVH can't be shown on cockpit UI via Internet Explorer 11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: cockpit-ovirt
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-4.0.4
: ---
Assignee: Marek Libra
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 10:15 UTC by cshao
Modified: 2016-09-29 12:44 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the cockpit-ovirt plugin was not operating in Internet Explorer 11, because Internet Explorer 11 does not support some Javascript functions. With this release, the cockpit-ovirt plugin works on Internet Explorer 11.
Clone Of:
Environment:
Last Closed: 2016-09-29 12:44:41 UTC
oVirt Team: Virt


Attachments (Terms of Use)
IE 11 (deleted)
2016-07-08 10:15 UTC, cshao
no flags Details
firefox (deleted)
2016-07-08 10:15 UTC, cshao
no flags Details
all-log (deleted)
2016-07-08 10:16 UTC, cshao
no flags Details
IE11-fixed (deleted)
2016-09-27 15:02 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1971 normal SHIPPED_LIVE cockpit-ovirt for RHV 4.0.4 2016-09-29 16:41:15 UTC
oVirt gerrit 63080 master MERGED vdsm: Avoid unsupported IE 11 JS functions 2016-08-31 14:09:18 UTC
oVirt gerrit 63082 ovirt-4.0 MERGED vdsm: Avoid unsupported IE 11 JS functions 2016-08-31 14:09:37 UTC

Description cshao 2016-07-08 10:15:24 UTC
Created attachment 1177595 [details]
IE 11

Description of problem:
VM info of RHVH can't be shown on windows Internet Explorer 11, it always show as "Loading VM list". No such issue on firefox.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-4.0-20160701.1
redhat-release-rhev-hypervisor-4.0-0.9.el7.x86_64 
imgbased-0.7.1-0.1.el7ev.noarch 
cockpit-ovirt-dashboard-0.10.6-1.1.0.el7ev.noarch
windows Internet Explorer 11 (version:11.0.9600.17843)

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH
2. Login cockpit on IE 11.
3. Deploy HE with correct steps.
4. After succeed deploy HE, switch to VM tab.

Actual results:
VM info of RHVH can't be shown on windows Internet Explorer 11, it always show as "Loading VM list". No such issue on firefox.

Expected results:
VM info of RHVH can be shown on windows Internet Explorer 11.

Additional info:

Comment 1 cshao 2016-07-08 10:15:51 UTC
Created attachment 1177596 [details]
firefox

Comment 2 cshao 2016-07-08 10:16:54 UTC
Created attachment 1177598 [details]
all-log

Comment 4 Yaniv Kaul 2016-07-25 07:14:43 UTC
Does it work well on Microsoft Edge and all other browser (Firefox, Chrome) on Windows?

Comment 5 cshao 2016-07-25 07:35:30 UTC
(In reply to Yaniv Kaul from comment #4)
> Does it work well on Microsoft Edge and all other browser (Firefox, Chrome)
> on Windows?

It can work well on Firefox and Chrome on windows, but we didn't cover Microsoft Edge browser due to no such test env.

Comment 8 cshao 2016-09-27 15:02:03 UTC
Test version:
redhat-virtualization-host-4.0-20160919.0
imgbased-0.8.5-0.1.el7ev.noarch 
cockpit-ws-0.114-2.el7.x86_64
cockpit-ovirt-dashboard-0.10.6-1.4.0.el7ev.noarch
windows Internet Explorer 11 (version:11.0.9600)

Steps to Reproduce:
1. Install RHVH
2. Login cockpit on IE 11.
3. Deploy HE with correct steps.
4. After succeed deploy HE, switch to VM tab.

Test result:
VM info of RHVH can be shown on windows Internet Explorer 11.

So the bug is fixed, change bug status to VERIFIED.

Comment 9 cshao 2016-09-27 15:02:36 UTC
Created attachment 1205263 [details]
IE11-fixed

Comment 11 errata-xmlrpc 2016-09-29 12:44:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1971.html


Note You need to log in before you can comment on or make changes to this bug.