Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353881 - ipa-replica-install suggests about non-existent --force-ntpd option
Summary: ipa-replica-install suggests about non-existent --force-ntpd option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 10:11 UTC by Abhijeet Kasurde
Modified: 2016-11-04 05:56 UTC (History)
4 users (show)

Fixed In Version: ipa-4.4.0-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:56:39 UTC


Attachments (Terms of Use)
console.log (deleted)
2016-08-19 05:57 UTC, Abhijeet Kasurde
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2016-07-08 10:11:05 UTC
Description of problem:
When ipa-replica-install runs without any option, then it suggests user for '--force-ntpd'.
But there is no option available for user in 'ipa-replica-install' which is misleading to user.

# ipa-replica-install 
Configuring client side components
WARNING: ntpd time&date synchronization service will not be configured as
conflicting service (chronyd) is enabled
Use --force-ntpd option to disable it and force configuration of ntpd

One of password / principal / keytab is required.
Installation failed. Rolling back changes.
IPA client is not configured on this system.
Removing client side components
IPA client is not configured on this system.

ipa.ipapython.install.cli.install_tool(Replica): ERROR    Configuration of client side components failed!
ipa.ipapython.install.cli.install_tool(Replica): ERROR    The ipa-replica-install command failed. See /var/log/ipareplica-install.log for more information
[root@vm136 quickinstall]# ipa-replica-install --force-ntpd 
Usage: ipa-replica-install [options] REPLICA_FILE

ipa-replica-install: error: no such option: --force-ntpd
[root@vm136 quickinstall]# rpm -q ipa-server
ipa-server-4.4.0-1.el7.x86_64



Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install IPA server RPMs
2. Without installing ipa-client-install trigger ipa-replica-install

Actual results:
user is presented with warning 'Use --force-ntpd option to disable it and force configuration of ntpd'


Expected results:
Remove unwanted suggestion of --force-ntpd

Comment 2 Petr Vobornik 2016-07-08 12:13:46 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6046

Comment 3 Martin Bašti 2016-08-11 13:35:08 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/0745c5d0f96f572a3780b32a3f2dce4f3512c396

Comment 5 Abhijeet Kasurde 2016-08-19 05:56:55 UTC
Verified using IPA version ::
ipa-server-4.4.0-8.el7.x86_64

Marking BZ as verified. See console.log for verification steps.

Comment 6 Abhijeet Kasurde 2016-08-19 05:57:14 UTC
Created attachment 1192034 [details]
console.log

Comment 8 errata-xmlrpc 2016-11-04 05:56:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.