Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353877 - Try to Disable image feature from Slave Node is resulting in indefinite wait
Summary: Try to Disable image feature from Slave Node is resulting in indefinite wait
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: 3.0
Assignee: Jason Dillaman
QA Contact: Parikshith
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1322504 1383917 1412948 1494421
TreeView+ depends on / blocked
 
Reported: 2016-07-08 09:48 UTC by Tanay Ganguly
Modified: 2017-12-05 23:31 UTC (History)
6 users (show)

Fixed In Version: RHEL: ceph-12.1.2-1.el7cp Ubuntu: ceph_12.1.2-2redhat1xenial
Doc Type: Bug Fix
Doc Text:
.Disabling image features is no longer incorrectly allowed on non-primary images With RADOS Block Device (RBD) mirroring enabled, non-primary images are expected to be read-only. Previously, an attempt to disable image features on non-primary images could cause an indefinite wait. This operation is now properly disallowed on non-primary images. As a result, an attempt to disable image features on such images fails with an appropriate error message.
Clone Of:
Environment:
Last Closed: 2017-12-05 23:31:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 16988 None None None 2016-08-10 19:06:47 UTC
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Tanay Ganguly 2016-07-08 09:48:32 UTC
Description of problem:
While trying to disable an image feature from Slave Node, its taking forever to complete ( It should Fail, but its getting executed indefinitely )

Version-Release number of selected component (if applicable):
ceph version 10.2.2-15.el7cp

How reproducible:
Always

Steps to Reproduce:
1. Try to disable an Image Feature from the Slave Node.
rbd feature disable new/gerrard9 deep-flatten --cluster slave


Actual results:
Its not Failing.

Expected results:
It should fail, as we don't support Write permission on Slave Node

Additional info:

Note: 
I know this is a known issue, but it needs to be fixed in future releases.
For now it would be good to exit or break, rather than waiting indefinitely.

Comment 7 Jason Dillaman 2016-11-02 19:08:43 UTC
@Bara: lgtm

Comment 14 errata-xmlrpc 2017-12-05 23:31:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.