Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353865 - [RFE] Remove required parents parameter when Snapshot class is created with origin set up
Summary: [RFE] Remove required parents parameter when Snapshot class is created with o...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 09:13 UTC by Jiri Konecny
Modified: 2016-07-13 19:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-13 19:40:14 UTC


Attachments (Terms of Use)

Description Jiri Konecny 2016-07-08 09:13:59 UTC
Description of problem:
When I want to create a LVM snapshot I need to specify parents of origin. There is no need to specify this, it can be easily read from origin so the parameter shouldn't be required.

LVMLogicalVolumeDevice(name=self.name,
                       parents=[origin_dev.parents[0]], # remove this line
                       seg_type="thin",
                       origin=origin_dev)

Version-Release number of selected component (if applicable):
2.0.2

How reproducible:
Always

Actual results:
Snapshot creation requires parents specified.

Expected results:
Snapshot creation should be fine without parents parameter when origin is specified.

Comment 1 David Lehman 2016-07-13 19:40:14 UTC
I am more interested in consistency than convenience when it comes to the blivet API. Anyone with experience instantiating blivet device classes would probably pass parents without even thinking about it since it is a required argument for all devices that have parents. I don't think this particular short-cut really gains you much in terms of convenience anyway.


Note You need to log in before you can comment on or make changes to this bug.