Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353863 - [Wayland?] Lots of warnings when running eclipse
Summary: [Wayland?] Lots of warnings when running eclipse
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lev Ufimtsev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 09:10 UTC by Christian Stadelmann
Modified: 2016-11-29 09:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-28 20:26:33 UTC


Attachments (Terms of Use)
Some output (stderr) of eclipse running with wayland Gdk3 backend (deleted)
2016-07-13 09:32 UTC, Christian Stadelmann
no flags Details


Links
System ID Priority Status Summary Last Updated
Eclipse Project 486068 None None None 2016-11-28 20:34:49 UTC
Eclipse Project 498076 None None None 2016-11-28 20:31:36 UTC

Description Christian Stadelmann 2016-07-08 09:10:26 UTC
Description of problem:


Version-Release number of selected component (if applicable):
eclipse-swt-4.6.0-0.6.git201605092000.fc24.x86_64
eclipse-platform-4.6.0-0.6.git201605092000.fc24.x86_64
gtk3-3.20.6-1.fc24.x86_64

How reproducible:
always on wayland. Not sure on x11 backends: warnings don't occur, but I guess they are just suppressed.

Steps to Reproduce:
1. start a terminal in a gnome+wayland or weston session
2. start eclipse
3. watch stdout/stderr

Actual results:
Dozens of warnings. Most of them are printed more than once. For example:

Gtk-WARNING **: Negative content width -6 (allocation 1, extents 4x3) while allocating gadget (node toolbar, owner GtkToolbar)

Gtk-WARNING **: Negative content height -3 (allocation 1, extents 2x2) while allocating gadget (node toolbar, owner GtkToolbar)

Gdk-WARNING **: Couldn't map window 0x7f448aa02730 as susburface because its parent is not mapped.

Gtk-WARNING **: Allocating size to GtkBox 0x7f448a198cf0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

Gtk-CRITICAL **: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

Gtk-WARNING **: Allocating size to GtkToolButton 0x7f448aaf4cd0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

Gtk-WARNING **: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node trough, owner GtkProgressBar)

Gtk-WARNING **: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node trough, owner GtkProgressBar)


Expected results:
Less warnings. Ideally none at all, but we don't live in an ideal world …

Additional info:
I can only reproduce this issue on wayland Gdk backends, but I think it is also present with x11 Gdk backend though Gdk/Gtk doesn't mind reporting this stuff to console.

Comment 1 Alexander Kurtakov 2016-07-08 09:17:01 UTC
Leo, work has started on this one, right?

Comment 2 Lev Ufimtsev 2016-07-11 16:50:44 UTC
Hello/guten Tag,

Thank you for bug submission. 

We normally have quite a number of warnings in the console when running eclipse.
Ex if you try to run ControlExample.java, one get's similar errors.

By 'normally' I mean we should not have those ideally, but do have them at the moment because we implement some custom container behaviour (which should be improved at some point).
 
Fixing them is sort of work-in-progress. I imagine on Wayland there may be more errors due to changes in sizing methods.

The above seem familiar. 

Would you be able to attach a complete log of errors so I can see if there are any new warnings and compare it to my output?

Thank you

Comment 3 Christian Stadelmann 2016-07-13 09:32:28 UTC
Created attachment 1179173 [details]
Some output (stderr) of eclipse running with wayland Gdk3 backend

(In reply to Lev Ufimtsev from comment #2)
> Hello/guten Tag,
Hi ;)

> Would you be able to attach a complete log of errors so I can see if there
> are any new warnings and compare it to my output?

I don't think "complete" is the correct word here since I didn't click every single button in eclipse ;), but here it is…

Comment 4 Lev Ufimtsev 2016-07-18 17:18:45 UTC
Hello Christian, 

Thank you for the attached log. It does seem there are some warnings on Wayland that are not on the regular X11 eclipse. Perhaps those warnings are related to the titlebars and other pop-ups appearing all over the place.

These issues are not specific to the red-hat ported Eclipse, but occur in the upstream version of Eclipse. 

I took the liberty of creating a bug in upstream:
498076: [Wayland] Additional warnings thrown in console
https://bugs.eclipse.org/bugs/show_bug.cgi?id=498076
Hopefully once I fix up WebKit2 port, I will try to investigate wayland issues.
(Note the parent of that task links to existing known issues, please feel free to submit additional wayland issues if you come across them).

I tried adding you in CC, but bugzilla oddly throws an error at me saying that your email address could not be matched against anything(?). Please feel free to add yourself to CC to followup on the bug. 

Btw, If you live so far on the edge as to use Wayland, consider using newer versions from Eclipse: 
http://download.eclipse.org/eclipse/downloads/
ex the integration or nightly builds are fairly stable for full-time use. The Eclipse in the Redhat/Fedora repository tends to be 3-7 months old and may not contain latest fixes.

Comment 5 Lev Ufimtsev 2016-11-28 20:26:33 UTC
Tracking to be contiuned in u upstream eclipse.

Comment 6 Mat Booth 2016-11-29 09:11:34 UTC
(In reply to Lev Ufimtsev from comment #4)
> Hello Christian, 
> 
> Thank you for the attached log. It does seem there are some warnings on
> Wayland that are not on the regular X11 eclipse. Perhaps those warnings are
> related to the titlebars and other pop-ups appearing all over the place.
> 
> These issues are not specific to the red-hat ported Eclipse, but occur in
> the upstream version of Eclipse. 
> 
> I took the liberty of creating a bug in upstream:
> 498076: [Wayland] Additional warnings thrown in console
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=498076
> Hopefully once I fix up WebKit2 port, I will try to investigate wayland
> issues.
> (Note the parent of that task links to existing known issues, please feel
> free to submit additional wayland issues if you come across them).
> 
> I tried adding you in CC, but bugzilla oddly throws an error at me saying
> that your email address could not be matched against anything(?). Please
> feel free to add yourself to CC to followup on the bug. 
> 
> Btw, If you live so far on the edge as to use Wayland, consider using newer
> versions from Eclipse: 
> http://download.eclipse.org/eclipse/downloads/
> ex the integration or nightly builds are fairly stable for full-time use.
> The Eclipse in the Redhat/Fedora repository tends to be 3-7 months old and
> may not contain latest fixes.

Thanks for taking care of this, Leo.


Note You need to log in before you can comment on or make changes to this bug.