Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1352877 - Empty Overview Menu
Summary: Empty Overview Menu
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Daniel Korn
QA Contact: Dave Johnson
URL:
Whiteboard: container:ui
Depends On:
Blocks: 1357519
TreeView+ depends on / blocked
 
Reported: 2016-07-05 11:12 UTC by Pavel Zagalsky
Modified: 2016-07-27 10:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1357519 (view as bug list)
Environment:
Last Closed: 2016-07-19 10:09:48 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Overview (deleted)
2016-07-05 11:12 UTC, Pavel Zagalsky
no flags Details

Description Pavel Zagalsky 2016-07-05 11:12:55 UTC
Created attachment 1176381 [details]
Overview

Description of problem:
There's nothing in the Containers --> Overview page

How reproducible:
Happens only on my current appliance, 
https://10.8.199.169/container_dashboard/show

Steps to Reproduce:
1. Go to Compute --> Containers --> Overview


Actual results:
There's nothing in the page

Expected results:
There should be an overview of the system

Additional info:
Check the attached log and screenshot
The current version is 5.6.0.13.20160624114606_13a9153

Comment 2 Daniel Korn 2016-07-13 12:47:14 UTC
The fix was merged to master in https://github.com/ManageIQ/manageiq/pull/9390,
but wasn't backported to darga.
The PR introduces lots of JS changes that aren't relevant for the bug. 
I think the best solution will be to send a new PR, including only the fix, to darga branch.

Comment 3 Mooli Tayer 2016-07-17 09:49:57 UTC
(In reply to Daniel Korn from comment #2)
> The fix was merged to master in
> https://github.com/ManageIQ/manageiq/pull/9390,
> but wasn't backported to darga.

Does this bug happen On Darga? 
Do we need a zstream clone of this bug?

Comment 4 Pavel Zagalsky 2016-07-17 10:12:31 UTC
I am not sure how I can check it.. Maybe Daniel can answer?

Comment 5 Daniel Korn 2016-07-17 10:35:28 UTC
(In reply to Mooli Tayer from comment #3)
> (In reply to Daniel Korn from comment #2)
> > The fix was merged to master in
> > https://github.com/ManageIQ/manageiq/pull/9390,
> > but wasn't backported to darga.
> 
> Does this bug happen On Darga? 
yes, it does.
> Do we need a zstream clone of this bug?
probably yes, I added the flag.

thanks Mooli!

Comment 6 Daniel Korn 2016-07-19 10:09:48 UTC
Digging into the issue it turns out it was fixed and merged into master by two PRs, that weren't specifically addressing the bug, but making general JS changes:
https://github.com/ManageIQ/manageiq/pull/9019
https://github.com/ManageIQ/manageiq/pull/9390 (same one I referred to in comment 2)

I'm closing this BZ and will submit a PR to darga which could be tested by Pavel (relevant 5.6.z BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1357519)

Comment 7 Pavel Zagalsky 2016-07-27 10:54:56 UTC
Fixed, thanks Daniel


Note You need to log in before you can comment on or make changes to this bug.