Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1348546 - CFME - add new provider - No error shown to user if Validation fails due to Openshift not responding
Summary: CFME - add new provider - No error shown to user if Validation fails due to O...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Julian Cheal
QA Contact: Einat Pacifici
URL:
Whiteboard: validation
Depends On:
Blocks: 1353930
TreeView+ depends on / blocked
 
Reported: 2016-06-21 12:21 UTC by Einat Pacifici
Modified: 2018-01-05 23:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1353930 (view as bug list)
Environment:
Last Closed: 2017-08-21 13:03:25 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Einat Pacifici 2016-06-21 12:21:58 UTC
Description of problem:
Provider's Master machine has firewall rule to deny access to http and https traffic on ports 80,8080, 443, 8443
CFME validation fails when trying to validate, but does not show error to user. 

Version-Release number of selected component (if applicable):
5.6.0.11

How reproducible:
Always

Steps to Reproduce:
1.On Openshift Master machine - add firewall rule to block http and https traffic (ports 80,8080, 8443, 443)
2.In CFME - add a new provider and click Validate


Actual results:
CFME does not show any indication of success/failure to user. 

Expected results:
CFME should show some indication (in this case) of failure to connect to Openshift

Additional info:
When deploying Openshift on GCE, GCE by default blocks https and http traffic. If a firewall rule is not specifically enabled, CFME will not be able to access the Provider on GCE.

Comment 2 Harpreet Kataria 2016-06-21 16:59:24 UTC
Greg,

Looks like UI display flash message correctly when Validate button is pressed on ADD new cloud provider with type as GCE. Pressing validate button with incorrect text in Service Account JSON field displays error flash message in red on screen. Probably with firewall s block http and https traffic validation is timed out and not raising timed out error message. Please take a look and send it back back to UI team if it happens to be a bug in UI code.

Thanks,
~Harpreet

Comment 5 Chris Pelland 2017-08-21 13:03:25 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.