Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1347788 - [abrt] nwchem-openmpi: dassertp_fail(): nwchem_openmpi killed by SIGSEGV
Summary: [abrt] nwchem-openmpi: dassertp_fail(): nwchem_openmpi killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nwchem
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: marcindulak
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d3405b23c02f213fcd06531965c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-17 15:56 UTC by Dmitry
Modified: 2016-08-08 20:29 UTC (History)
1 user (show)

Fixed In Version: nwchem-6.6.27746-27.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-08 20:29:50 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: cgroup (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: core_backtrace (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: dso_list (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: environ (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: limits (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: maps (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: mountinfo (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: namespaces (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: open_fds (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: proc_pid_status (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details
File: var_log_messages (deleted)
2016-06-17 15:56 UTC, Dmitry
no flags Details

Description Dmitry 2016-06-17 15:56:30 UTC
Description of problem:
1. source /etc/profile.d/nwchem.sh - done!
2. module load mpi/openmpi-x86_64 - done!
3. Start any .nw file using mpiexec - error: Error no. 1  in getmem  memory overflow : call no., amount requested :   85               225970
 texas: nerror called
4. Add to .nw file option memory 225970 - SIGSEGV
5. Increase shmmax, start .nw file - nwchem fails

Version-Release number of selected component:
nwchem-openmpi-6.6.27746-24.fc24

Additional info:
reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        nwchem_openmpi am_no2f.nw
crash_function: dassertp_fail
executable:     /usr/lib64/openmpi/bin/nwchem_openmpi
global_pid:     19664
kernel:         4.5.5-300.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (8 frames)
 #10 dassertp_fail at src/common/armci.c:1008
 #11 pnga_error at global/src/global.util.c:363
 #12 nga_error_ at global/src/fapi.c:1463
 #13 errquit at errquit.F:144
 #14 memory_defaults at memory_def.F:406
 #15 memory_input at memory_input.F:161
 #16 input_mem_size at input_mem.F:36
 #17 nwchem at nwchem.F:126

Comment 1 Dmitry 2016-06-17 15:56:35 UTC
Created attachment 1169159 [details]
File: backtrace

Comment 2 Dmitry 2016-06-17 15:56:36 UTC
Created attachment 1169160 [details]
File: cgroup

Comment 3 Dmitry 2016-06-17 15:56:37 UTC
Created attachment 1169161 [details]
File: core_backtrace

Comment 4 Dmitry 2016-06-17 15:56:39 UTC
Created attachment 1169162 [details]
File: dso_list

Comment 5 Dmitry 2016-06-17 15:56:40 UTC
Created attachment 1169163 [details]
File: environ

Comment 6 Dmitry 2016-06-17 15:56:41 UTC
Created attachment 1169164 [details]
File: limits

Comment 7 Dmitry 2016-06-17 15:56:43 UTC
Created attachment 1169165 [details]
File: maps

Comment 8 Dmitry 2016-06-17 15:56:45 UTC
Created attachment 1169166 [details]
File: mountinfo

Comment 9 Dmitry 2016-06-17 15:56:46 UTC
Created attachment 1169167 [details]
File: namespaces

Comment 10 Dmitry 2016-06-17 15:56:48 UTC
Created attachment 1169168 [details]
File: open_fds

Comment 11 Dmitry 2016-06-17 15:56:49 UTC
Created attachment 1169169 [details]
File: proc_pid_status

Comment 12 Dmitry 2016-06-17 15:56:50 UTC
Created attachment 1169170 [details]
File: var_log_messages

Comment 13 marcindulak 2016-07-15 14:23:29 UTC
maybe related to bug #1356735

Comment 14 Fedora Update System 2016-07-16 17:00:42 UTC
nwchem-6.6.27746-26.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f10b67dbd7

Comment 15 marcindulak 2016-07-16 17:02:55 UTC
Looks we experienced the same problem as Debian maintainers of Nwchem:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=767481

Native optimization compiler flags were on and the build produced by koji were not portable.

Comment 16 Fedora Update System 2016-07-18 22:26:11 UTC
nwchem-6.6.27746-26.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f10b67dbd7

Comment 17 Dmitry 2016-07-19 11:14:27 UTC
(In reply to Fedora Update System from comment #16)
> nwchem-6.6.27746-26.fc24 has been pushed to the Fedora 24 testing
> repository. If problems still persist, please make note of it in this bug
> report.
> See https://fedoraproject.org/wiki/QA:Updates_Testing for
> instructions on how to install test updates.
> You can provide feedback for this update here:
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-f10b67dbd7

Doesn't work for me.

I recieved the same message:
Attempting to read a basis set from a  non-existing file:
 /builddir/build/BUILD/nwchem-6.6/src/basis/libraries/6-311gs

Comment 18 marcindulak 2016-07-19 11:50:03 UTC
Are you sure the env variables are set:

0. source /etc/profile.d/nwchem.sh&& echo $NWCHEM_BASIS_LIBRARY

Comment 19 Dmitry 2016-07-19 13:23:27 UTC
Yes:

[madchem@desktop ~]$ source /etc/profile.d/nwchem.sh && $NWCHEM_BASIS_LIBRARY
bash: /usr/share/nwchem/libraries/:/usr/nwchem/libraries/: No such file or directory

And then:

[madchem@desktop ~]$ mpiexec -np 4 `which nwchem_openmpi` test.nw
...
  warning:::::::::::::: from_environment
  NWCHEM_BASIS_LIBRARY set to: </usr/share/nwchem/libraries/:/usr/nwchem/libraries/>
  but file does not exist !
  using .nwchemrc or compiled library
  warning:::::::::::::: from_compile
  NWCHEM_BASIS_LIBRARY is: </builddir/build/BUILD/nwchem-6.6/src/basis/libraries/>
  but file does not exist or you do not have access to it !
 Attempting to read a basis set from a  non-existing file:
 /builddir/build/BUILD/nwchem-6.6/src/basis/libraries/6-31g

And:

[madchem@desktop ~]$ locate 6-31g
/usr/share/nwchem/libraries/6-31g
/usr/share/nwchem/libraries/6-31g-blaudeau
/usr/share/nwchem/libraries/6-31g3df_3pd
/usr/share/nwchem/libraries/6-31gs
/usr/share/nwchem/libraries/6-31gs-blaudeau
/usr/share/nwchem/libraries/6-31gs_polarization
/usr/share/nwchem/libraries/6-31gss
/usr/share/nwchem/libraries/6-31gss_polarization
/usr/share/nwchem/libraries/m6-31g
/usr/share/nwchem/libraries/m6-31gs
/usr/share/nwchem/libraries/qmmm_zhang_6-31gs_ecp
/usr/share/nwchem/libraries/s6-31g
/usr/share/nwchem/libraries/s6-31gs

I tried to compile nwchem on my machine. But as I get executable file, it returns SEGFAULT. I'm frustrated with it...

Comment 20 marcindulak 2016-07-19 13:37:37 UTC
This is the problem:

bash: /usr/share/nwchem/libraries/:/usr/nwchem/libraries/: No such file or directory

you need:

unset NWCHEM_BASIS_LIBRARY
unset NWCHEM_NWPW_LIBRARY
source /etc/profile.d/nwchem.sh

I see the NWCHEM variables must not be prepended, just set to a single path. I fix that at the coming nwchem-6.6.27746-27 build.

Look at bug #1356735 - currently the nwchem-6.6.27746-26 executables are broken due to some gfortran 6 flags used during the build.

Comment 21 Dmitry 2016-07-19 15:13:42 UTC
Oh! Thank you very much!!!

It works!

Comment 22 Fedora Update System 2016-07-20 07:21:59 UTC
nwchem-6.6.27746-27.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-96b3062018

Comment 23 Fedora Update System 2016-07-21 04:21:41 UTC
nwchem-6.6.27746-27.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-96b3062018

Comment 24 Fedora Update System 2016-08-08 20:29:46 UTC
nwchem-6.6.27746-27.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.