Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1346817 - [ALL LANG] 'New' and 'Import' buttons of 'Networks' tab are overlapping in resized browser window
Summary: [ALL LANG] 'New' and 'Import' buttons of 'Networks' tab are overlapping in re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.0.0
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.1.0-alpha
: 4.1.0.2
Assignee: Alexander Wels
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
: 1365453 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-15 11:48 UTC by Krishna Babu K
Modified: 2017-02-01 14:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:56:20 UTC
oVirt Team: UX
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
oourfali: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)
Screen shot reference for the reported issue. (deleted)
2016-06-15 11:48 UTC, Krishna Babu K
no flags Details
Screen shot references for the reported issue with rhevm-4.0.2-0.2.rc1.el7ev. (deleted)
2016-07-15 12:01 UTC, Krishna Babu K
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 61118 master MERGED webadmin: Fix scrollable tab bar width calculation 2016-07-22 17:21:40 UTC

Description Krishna Babu K 2016-06-15 11:48:54 UTC
Created attachment 1168335 [details]
Screen shot reference for the reported issue.

Description of problem:
  While accessing 'Administration Portal' using firefox, in resized window mode 'New' and 'Import' buttons of 'Networks' tab overlapping.

Version-Release number of selected component (if applicable):
  4.0.0.4-0.1

How reproducible:
  Always

Steps to Reproduce:
1. Log into ovirt-engine Administration portal using firefox

2. Resize the browser window, for e.g. 1257x860 or lesser.

3. Click on 'Networks' list item on left side 'System' pane (One can observe 
   'New' and 'Import' buttons are appearing clearly)

4. Now click on 'System' list item on left side 'System' pane ('New' and 
   'Import' buttons are overlapping)

Actual results:
  UI buttons are overlapping in resized window.

Expected results:
  Overlapping should not be there.

Additional info:
  Attached screen shot for reference.

Comment 1 Oved Ourfali 2016-06-29 09:03:01 UTC
This is specific on the network dialog, as far as I saw.
Moving back to network.
Not sure why it was moved back without any comment whatsoever.

If it is a generic issue then it should be presented as such.

Comment 2 Yaniv Lavi 2016-06-29 09:12:50 UTC
Does this happen with RHEV 3.6?

Comment 3 Michael Burman 2016-06-29 10:18:48 UTC
I don't see this issue on rhevm-4.0.0.6-0.1.el7ev.noarch and not on  3.6.7.5-0.1.el6(firefox and chrome)

Comment 4 Marcin Mirecki 2016-07-11 16:08:25 UTC
I can not reproduce this on my setup (ovirt 4.0, firefox 42). 
Is this a recurring problem? Does it happen every time, even after browser restart?
Can you please check if this happens after clearing browser cache?
Also please give me the browser version you are using.

Comment 5 Krishna Babu K 2016-07-15 11:55:27 UTC
Verified RHEVM-4.0.2-0.2.rc1.el7ev on firefox-47.0-4.fc23.x86_64
Still reproducible for en_US, de_DE, fr_FR, it_IT, ja_JP and zh_CN.
Attaching reference screen-shots for all languages having this issue.

Comment 6 Krishna Babu K 2016-07-15 12:00:43 UTC
Basically it happens when i click 'Any list item' from left side pane and click back the 'System'. Previously i mentioned 'Networks' for example, but it happens when i click on any list item and click back on 'system'.

Comment 7 Krishna Babu K 2016-07-15 12:01:50 UTC
Created attachment 1180123 [details]
Screen shot references for the reported issue with rhevm-4.0.2-0.2.rc1.el7ev.

Comment 8 Yaniv Lavi 2016-07-20 08:08:25 UTC
Please take a look at the comment #6, since it seems UX related.

Comment 9 Oved Ourfali 2016-07-20 08:09:44 UTC
Alexander - can you take a look?

Comment 10 Alexander Wels 2016-07-20 12:34:07 UTC
Comment #6 gives the right reproducer, should be a fairly easy fix.

Comment 11 Bhushan Barve 2016-08-10 09:55:02 UTC
*** Bug 1365453 has been marked as a duplicate of this bug. ***

Comment 12 Sandro Bonazzola 2016-12-12 14:00:50 UTC
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.

Comment 13 Lucie Leistnerova 2016-12-15 16:12:34 UTC
no tabs are overlapping

verified in ovirt-engine-webadmin-portal-4.1.0-0.2.master.20161215130926.git1e1810e.el7.centos.noarch


Note You need to log in before you can comment on or make changes to this bug.