Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 134507 - Hang at "Initializing hardware... storage network" caused by snd-maestro3 driver load.
Summary: Hang at "Initializing hardware... storage network" caused by snd-maestro3 dri...
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
Depends On:
Blocks: FC3Target FC4Target FC5Target
TreeView+ depends on / blocked
Reported: 2004-10-04 05:38 UTC by Charles R. Anderson
Modified: 2015-01-04 22:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-11-28 19:27:28 UTC

Attachments (Terms of Use)
Full lscpi listing (deleted)
2004-10-04 05:42 UTC, Charles R. Anderson
no flags Details
ACPI dmidecode output (deleted)
2005-10-06 21:23 UTC, Charles R. Anderson
no flags Details
candidate fix (deleted)
2005-10-17 19:32 UTC, Charles R. Anderson
no flags Details | Diff
patch as applied to ALSA CVS (deleted)
2005-10-24 16:58 UTC, Charles R. Anderson
no flags Details | Diff

Description Charles R. Anderson 2004-10-04 05:38:49 UTC
Description of problem:

I have an HP Omnibook 6000 with a fresh install of todays rawhide. 
Kernel hangs upon loading snd-maestro3 driver during hardware
initialization (see bug #133910).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Power down laptop, boot up Windows 2000.  Observe audio works fine.
2. Boot up FC.  Audio initializes properly, no hang.  Sound works.
3. Reboot.  Hangs at audio init.
Actual results:

Initializing hardware... storage network

System hangs.  Capslock no longer toggles LED.  Ctrl-Alt-Del and
Alt-SysRq-B don't work.  I had to boot with init=/bin/sh after this
happened.  Manual loading of the driver results in the same hang and
the following log message:

#/sbin/modprobe snd-maestro3
ACPI: PCI interrupt 0000:00:0d:0[A] -> GSI 5 (level, low) -> IRQ 5

Expected results:

snd-maestro3 should initialize the hardware properly after a reboot,
and not require Windows to be booted immediately prior in order to
work properly.

Additional info:

HP Omnibook 6000, Pentium III 600MHz.

00:0d.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i
PCI Audio Accelerator

Comment 1 Charles R. Anderson 2004-10-04 05:42:58 UTC
Created attachment 104704 [details]
Full lscpi listing

Comment 2 Jorge A. Aquino 2004-11-26 21:46:11 UTC
I have the same problem -- with Toshiba Satellite 2805-S201.

Upgraded to FC3, booted, and hung up on udev initializing hardware
.... storage network audio

tried to find way to update the udev package, but could not access the
cdrom to install the rpm.

Comment 3 Duluth Trading Company 2004-12-07 22:24:41 UTC
Same problem with Toshiba Tecra 8200

Comment 4 Toby Buck. 2004-12-08 04:10:08 UTC
Same problem on a Toshiba Tecra 8200.

Comment 5 Toby Buck. 2004-12-08 04:11:06 UTC
I meant same on a Tecra 8100.

Comment 6 Guillermo Narvaez 2004-12-24 01:59:08 UTC
Same problem on a Toshiba Tecra 8200. 

FC2 worked fine and install flawlessly, but FC3 does not. Tried a
clean install, as well as upgrading from FC2.

Comment 10 Henro 2005-01-02 08:53:34 UTC
Upgraded to FC3, booted, and hung up on udev initializing hardware
.... storage network audio

Exactly same thing is happening on a Toshiba Tecra 8100

Comment 11 darryl Balaski 2005-01-06 03:00:49 UTC
I had the exact same problem on my Tecra 8100 --  a fresh install on a
20GB partition of a 60G drive.

by chance from something I read, i tried to boot without acpi support
in grub,  I edited the kernel line to add acpi=off
kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVo100 rhgb
quiet acpi=off

and everything worked fine after that

Comment 12 U. Elias 2005-01-22 18:51:08 UTC
Similar to the above with one difference:

After "Initializing hardware ... storage network audio"  the booting
freezes.  But if I turn off electricity and boot immediately again, it
boots properly and works fine.
I tried to remove rhgb from grub command line or add acpi=off without
any effect.

Reproducable: Always

Motherboard: Intel GA-8PE667, Chipset: 845G
Sound card: Intel 82801DB   AC'97 audio controller, module: snd-intel8x0

Comment 13 Luke Hutchison 2005-01-27 04:17:39 UTC
I have a Shuttle XPC SN95G5 desktop system which boots fine in FC3,
and booted fine with fedora-development kernels until the 2.6.10-...
series.  With the new kernels, my boot process stops at the same point.

kernel-2.6.8-1.624  ** All these OK **
kernel-2.6.10-1.1089_FC4  ** Stopped working here **

Would lshal or lspci output help?

Comment 14 Luke Hutchison 2005-01-27 05:38:11 UTC
Sorry, please ignore the last message.  It is unrelated (my machine
stops after "storage network audio done").  It is actually only a
problem when my USB Microsoft Natural Keyboard Pro is plugged in. 
Unplugging it fixes the problem.  I will create a different Bugzilla
entry for this.

Comment 15 U. Elias 2005-01-27 07:28:42 UTC
Comment #12 continued:

I upgraded the system with  "yum update", now it runs kernel
vmlinuz-2.6.10-1.741_FC3 (instead vmlinuz-2.6.9-1.667 before)
and the problem disappeared.

Comment 16 Guy Rix 2005-02-28 14:51:10 UTC
Same problem on Tectra 8200

How do you install vmlinuz-2.6.10-1.741_FC3 to a system that won't 
RBoot into Rescue mode ?

Comment 17 Luke Hutchison 2005-02-28 16:09:17 UTC
I have fixed broken installs before by booting off the Fedora install
or rescue CD using "linux rescue", then following the directions to
mount the regular filesystem hierarchy (I think it's "chroot
/mnt/sysimage").  From that point on RPM seems to work just fine.  You
can use the programs "links" or "wget" (if you know the URL, in the
latter case) to actually get the packages you need to install.

Comment 18 Guy Rix 2005-03-02 14:23:35 UTC
Thanks - I think I have discovered a workaround
I cannot take all the credit - in fact none really.
As this workaround is a combination of 2 separate fixes from 
different sources (none which are mine).
1 - To get the Tecra 8200 laptop to boot do -

Boot with the FC3 disk1 into Rescue mode (linux rescue).Then 
vi /etc/rc.sysinit (i.e. /mnt/sysimage/etc/rc.sysinit) and comment 
out the part that reads:

# Sound
# for module in `/sbin/modprobe -c | awk '/^alias[[:space:]]+snd-card-
[[:digit:]]+[[:space:]]/ { print $3 }'` $audio; do
# load_module $module
# done
# echo -n $" audio"

Save and reboot without CD...

You can now boot without sound

2- Download kernel-2.6.10-1.741_FC3.nogin RPM for i686
Install as root using
rpm -iv kernel-2.6.10-1.741_FC3.nogin.i686.rpm

Then amend /etc/rc.sysinit back to the original state ( i.e. take the 
comments out that you added in step 1)

Then reboot and pick the new kernel via grub
All seems to work for me.

Hope it helps ?

Comment 19 Jorge A. Aquino 2005-03-04 21:05:09 UTC
I had just about given up on FC3 for my laptop -- until reading
daryl's post above about leaving acpi=off

That appears to have done the trick for me. Thanks for this tip.

Comment 20 Dave Jones 2005-10-06 03:05:51 UTC
Any improvement on this issue with the latest errata kernel ?

Comment 21 Charles R. Anderson 2005-10-06 18:43:47 UTC
2.6.10-1.766_FC3 still had the original problem.

2.6.12-1.1378_FC3 also still has the original problem.

Comment 22 Charles R. Anderson 2005-10-06 21:02:34 UTC
2.6.12-1.1378_FC3 reports these messages upon module load, with the exact same
symptoms as reported initially.  insmod was used instead of modprobe to prevent
any other modprobe.conf actions from running.

Boot with "init=/bin/sh" instead of "rhgb quiet".

sh-3.00# cd /lib/modules/2.6.12-1.1378_FC3/kernel/sound
sh-3.00# /sbin/insmod soundcore.ko
sh-3.00# /sbin/insmod core/snd.ko
sh-3.00# /sbin/insmod core/snd-timer.ko
sh-3.00# /sbin/insmod core/snd-page-alloc.ko
sh-3.00# /sbin/insmod core/snd-hwdep.ko
sh-3.00# /sbin/insmod core/snd-pcm.ko
sh-3.00# /sbin/insmod pci/ac97/snd-ac97-codec.ko
sh-3.00# /sbin/insmod pci/snd-maestro3.ko
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:00:0d.0[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5

Kernel hangs at this point.  No sysrq keys work.

Comment 23 Charles R. Anderson 2005-10-06 21:23:30 UTC
Created attachment 119690 [details]
ACPI dmidecode output

Here is the output of dmidecode on this HP Omnibook 6000 under kernel

Comment 24 Charles R. Anderson 2005-10-06 22:24:15 UTC
Cold booting from a power-off state with acpi=off does not make any difference
for my HP Omnibook 6000.  I get the same hang.

Comment 25 Ian Donaldson 2005-10-09 11:40:16 UTC
Found similar hang on 2.6.13-1.1526_FC4smp on 3.06GHz P4 with HT enabled;
was with a Microsoft Wheel Optical mouse on USB.  Moved it to a different USB
port and the hang vanished.

Comment 26 Charles R. Anderson 2005-10-10 21:30:11 UTC
I updated the HP Omnibook 6000 to FC4 and it's latest kernel 2.6.13-1.1526_FC4.
The same problem exists with this release and kernel.

Comment 27 Charles R. Anderson 2005-10-11 16:22:05 UTC
I updated to rawhide.  Kernel 2.6.13-1.1600_FC5 has the same problem.

Comment 28 Charles R. Anderson 2005-10-16 15:10:23 UTC
Upstream bug report:

Comment 29 Charles R. Anderson 2005-10-17 19:32:29 UTC
Created attachment 120074 [details]
candidate fix

The attached patch linux-2.6-maestro3-assp-init.patch fixes this issue for me.
It seems that the driver tries to start the ASSP before downloading the DSP
code to it, which explains why booting Windows before warm-booting Linux works.
A warm boot must not clear the DSP memory, which allows the ASSP startup to

The fix is to call the snd_m3_assp_init function to write the DSP firmware into
the ASSP chip before sending the RUN_ASSP command. I also made the same fix in
the OSS driver, but I did not test the OSS fix since it is disabled in Fedora.

Comment 30 Charles R. Anderson 2005-10-19 15:42:32 UTC
Kernel packages for FC3, FC4, and development containing this fix are available
for testing.  If you have a maestro3 sound card with this problem, please test
these packages and report your results in this bug:

yum repo:

name=Charles R. Anderson - $releasever - maestro3 fix


Comment 31 Charles R. Anderson 2005-10-24 16:58:35 UTC
Created attachment 120311 [details]
patch as applied to ALSA CVS

Here is the patch as it was applied to ALSA CVS.  Can this be added to the
development kernel RPM until it propagates into Linus' tree?


Comment 32 faber 2005-11-08 08:47:11 UTC
I had the exact same problem on my OB 6000 and patch fix maestro3 module.    
I have linux-2.6-maestro3-assp-init.patch + linux 2.6.14-rc4 and snd_maestro3   
as module.  
lspci: ESS Technology ES1983S Maestro-3i PCI Audio Accelerator   
Big THX for this patch.  

Comment 33 Dave Jones 2005-11-28 19:27:28 UTC
that patch is merged upstream, and is present in the current FC4 update, as well
as rawhide kernels.

Note You need to log in before you can comment on or make changes to this bug.