Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 133937 - chkfontpath doesn't properly parse font path on single line
Summary: chkfontpath doesn't properly parse font path on single line
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: chkfontpath
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-09-28 15:39 UTC by Brian Thomason
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.0.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-27 11:09:34 UTC


Attachments (Terms of Use)

Description Brian Thomason 2004-09-28 15:39:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20040414 Debian/1.5-2.0.0.lindows0.0.67.45+0

Description of problem:
chkfontpath does not properly parse the font paths listed in
/etc/X11/fs/config if they are all listed on one line:

For instance:

catalogue = /usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/cyrillic/

However, if listed on individual lines, it parse them properly:

catalogue = /usr/lib/X11/fonts/misc/,
            /usr/lib/X11/fonts/cyrillic/

-Brian

Version-Release number of selected component (if applicable):
chkfontpath-1.10.0-2.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install chkfontpath
2. Ensure all font paths in /etc/X11/fs/config are listed on one line
3. Run chkfontpath
    

Additional info:

Comment 1 Mike A. Harris 2004-12-23 19:48:17 UTC
Do you have a patch to fix this that you'd like me to apply to
future chkfontpath releases?

I ask because our tools always write out one path per line, so
this shouldn't ever be a huge problem per se.

Comment 3 Brian Thomason 2005-08-30 17:41:08 UTC
Hi Mike,

It's funny you dug this back up now as I just ran into the problem again the
other day.  However, It appears to be fixed in 2.0.1 - Thanks!

-Brian


Note You need to log in before you can comment on or make changes to this bug.