Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 133803 - Sort by date on threaded view does not update properly
Summary: Sort by date on threaded view does not update properly
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2004-09-27 16:40 UTC by Edward Rousseau
Modified: 2015-04-12 23:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-02 18:51:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 203206 None None None Never

Description Edward Rousseau 2004-09-27 16:40:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
When threaded viewing is enabled for a folder and the messages are
sorted by date, Evolution seems to use the date of the Parent email to
determine the position of the thread in the email list. It would be my
expectation that Evolution use the the date of the latest child in the
thread to determine the position in the date sorted list view.

As it stands now a user must either scroll to see if any new replies
exist to the thread or toggle out of threaded view to see the new
child message (and lose context). 



Version-Release number of selected component (if applicable):
2.0.0

How reproducible:
Always

Steps to Reproduce:
1. Enable threaded viewing on a folder and choose to sort by date.
2. Get a reply to an earlier message.
3. Message thread is not promoted to the top of the date sorted list.
    

Actual Results:  Thread not promoted in the list view.

Expected Results:  Thread sorted by latest email in the thread and not
parent email.

Additional info:

Comment 1 Dave Malcolm 2005-08-23 01:09:35 UTC
(related upstream bugs appear to be http://bugzilla.gnome.org/show_bug.cgi?id=309701
and
http://bugzilla.gnome.org/show_bug.cgi?id=243463)



Comment 3 Matthew Barnes 2007-01-02 18:51:18 UTC
This is still not supported in Evolution 2.9.4.  The upstream bugs referenced in
comment #1 appear to be about sorting messages within a thread, if I understand
them correctly.  Ed's request deals with sorting the threads themselves.

I found an upstream bug that seems to be requesting the same thing, so I'm
closing this bug as UPSTREAM.  Please refer to [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=203206


Note You need to log in before you can comment on or make changes to this bug.