Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1337626 - The kdump Anaconda addon TUI should display reserved memory range
Summary: The kdump Anaconda addon TUI should display reserved memory range
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Dave Young
QA Contact: Emma Wu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-19 16:32 UTC by Martin Kolman
Modified: 2017-06-27 05:24 UTC (History)
5 users (show)

Fixed In Version: kexec-tools-2.0.7-41.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 06:56:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2466 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2016-11-03 14:06:31 UTC

Description Martin Kolman 2016-05-19 16:32:37 UTC
Description of problem:
The kdump addon TUI checks user suggested reserved memory size but does not display it anywhere. This complicates inputting a valid value quite a bit, especially as the range changes due to RAM size and other factors.

Version-Release number of selected component (if applicable):
Kdump in RHEL 7.2

How reproducible:
always

Steps to Reproduce:
1. start installation in text mode
2. enter the kdump spoke
3. try to set the amount of reserved memory

Actual results:
The option simply says "Reserve amount(MB)" without any indication which values are accepted. The basically has to guess which value fits to the expected range as incorrect input only returns the unhelpful "You have provided an invalid value" error message.

Expected results:
The option shows the range of valid reserved memory values, for example:

"Reserve amount (128-1792 MB)"

This makes it easy for the user to set the correct value.

Additional info:
I have opened a pull request that makes the kdump addon TUI display the valid reserved memory range:
https://github.com/daveyoung/kdump-anaconda-addon/pull/10

Comment 7 errata-xmlrpc 2016-11-04 06:56:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2466.html


Note You need to log in before you can comment on or make changes to this bug.