Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1337343 - Upgrade to Fedora 24 breaks linkchecker [NEEDINFO]
Summary: Upgrade to Fedora 24 breaks linkchecker
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linkchecker
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: W. Michael Petullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1340043 (view as bug list)
Depends On:
Blocks: 1358471
TreeView+ depends on / blocked
 
Reported: 2016-05-18 22:19 UTC by W. Michael Petullo
Modified: 2016-07-28 23:55 UTC (History)
4 users (show)

Fixed In Version: linkchecker-9.3-5.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-28 23:55:13 UTC
cstratak: needinfo? (redhat)


Attachments (Terms of Use)
python-requests version error fix (deleted)
2016-07-19 12:52 UTC, Charalampos Stratakis
no flags Details | Diff

Description W. Michael Petullo 2016-05-18 22:19:02 UTC
Description of problem:
I found that linkchecker no longer works after upgrading from Fedora 23 to 24.

Version-Release number of selected component (if applicable):
linkchecker-9.3-4.fc24.x86_64
python-2.7.11-4.fc24.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Upgrade to Fedora 24
2. Run linkchecker

Actual results:
$ linkchecker 
This program requires Python requests 2.2.0 or later.
$ rpm -q python
python-2.7.11-4.fc24.x86_64

Comment 1 W. Michael Petullo 2016-05-20 15:06:20 UTC
I found this in linkchecker's __init__.py:

import requests
if requests.__version__ <= '2.2.0':
    raise SystemExit("This program requires Python requests 2.2.0 or later.")

This lexicographical order check malfunctions on Fedora 24 because of the use of requests 2.10.0.

Another user reported this upstream:

https://github.com/wummel/linkchecker/issues/649

Comment 2 Charalampos Stratakis 2016-07-19 12:34:47 UTC
Upstream commit where this is fixed:

https://github.com/wummel/linkchecker/commit/c2ce810c3fb00b895a841a7be6b2e78c64e7b042

However a newer version including this fix is not yet released. Maintainer could you backport the patch or use a git snapshot?

This currently breaks builds of python-docs with the same error message.

Comment 3 Charalampos Stratakis 2016-07-19 12:52:55 UTC
Created attachment 1181632 [details]
python-requests version error fix

Here is a patch for the package sources that fixes the issue.

It would be great if you could fix it in rawhide as well as F24.

Thank you for your time.

Comment 4 Fedora Update System 2016-07-19 21:05:42 UTC
linkchecker-9.3-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7aae6a4b50

Comment 5 Fedora Update System 2016-07-21 04:22:19 UTC
linkchecker-9.3-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7aae6a4b50

Comment 6 Charalampos Stratakis 2016-07-21 08:23:01 UTC
*** Bug 1340043 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2016-07-28 23:55:10 UTC
linkchecker-9.3-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.