Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1337229 - performance issues with QoS
Summary: performance issues with QoS
Keywords:
Status: CLOSED DUPLICATE of bug 1366556
Alias: None
Product: mom
Classification: oVirt
Component: Core
Version: 0.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.1.0-alpha
: ---
Assignee: Jenny Tokar
QA Contact: Shira Maximov
URL:
Whiteboard:
Depends On: 1337228 1343960
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-18 14:40 UTC by Michal Skrivanek
Modified: 2016-09-27 15:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 15:43:20 UTC
oVirt Team: SLA
michal.skrivanek: ovirt-4.1?
michal.skrivanek: planning_ack?
michal.skrivanek: devel_ack?
michal.skrivanek: testing_ack?


Attachments (Terms of Use)

Description Michal Skrivanek 2016-05-18 14:40:21 UTC
iotune QoS is using a problematic design requiring excessive use of vdsm (and libvirt) API calls
It can be done more effectively if we take few assumptions (maybe specific to vdsm, but still worth it)

There is no need to query and set policy and values periodically, no one can change the policy without engine and vdsm knowledge.
Changes can be reported as part of VM stats if needed, one field serving as a trigger would be ok. Since VM stats is being queried by mom already there would be no need for any additional calls in stable conditions.

I'm not sure about networking QoS

Comment 1 Martin Sivák 2016-09-27 15:43:20 UTC

*** This bug has been marked as a duplicate of bug 1366556 ***


Note You need to log in before you can comment on or make changes to this bug.