Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1337017 - [RFE] NoVNC Console troublesooting steps needs to add to trust katello server CA
Summary: [RFE] NoVNC Console troublesooting steps needs to add to trust katello server CA
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Melanie Corr
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks: 1516059
TreeView+ depends on / blocked
 
Reported: 2016-05-18 04:41 UTC by Fred van Zwieten
Modified: 2019-04-01 20:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-24 10:56:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1314423 None None None Never

Description Fred van Zwieten 2016-05-18 04:41:11 UTC
Description of problem:
I could not get the NoVNC console to work, even after following all trouleshoot steps I get when pressing the troubleshooting button (http://theforeman.org/manuals/1.11/index.html#7.1NoVNC). Afer much digging around, I found the solution. It was on this page: http://www.katello.org/docs/3.0/installation/index.html (first note):

After installation of Katello, be sure to trust Katello’s CA certificate on your system. This is required for the encrypted NoVNC connections. You will find katello-default-ca.crt in the /pub directory of your Katello server (e.g. http://katello.example.com/pub/katello-default-ca.crt).

It would be great if the troubleshooting steps on the foreman manual could be enhanced to include this. The CA should be trusted for websites only and you need to restart your browser for it to work.

Version-Release number of selected component (if applicable):
6.2 BETA

How reproducible:
Try to open a NoVNC console on libvirt with TLS

Steps to Reproduce:
1.
2.
3.

Actual results:
not working

Expected results:
working

Additional info:

Comment 2 Andrew Dahms 2017-11-16 00:41:52 UTC
Assigning to Melanie for review.

Melanie - another bug related to noVNC asking for further clarification of certificates and trust. I suspect this might be addressed by the content in the KBase, but I am passing it on to you for consideration.

Feel free to close this as a duplicate if you think the scope of work in that bug cover this.

Comment 4 Steve Bream 2017-11-21 10:50:22 UTC
Hi Melanie,

I think you're right. I'm not sure why (or even how) I dropped this content originally, but I think that it should remain in the Host Config guide ("Configuring Satellite Hosts" for 6.3) as the steps are required for provisioning, but *are* host configuration steps.

Let's reinstate the content that Stephen had created in the Host Config guide and continue to point to it from elsewhere in that guide, and leave the section in the provisioning guide as-is.

Thanks,
Steve

Comment 10 Melanie Corr 2017-11-24 10:56:13 UTC
Closing as this issue will be resolved with the plans for the the Server Administration guide.

*** This bug has been marked as a duplicate of bug 1314423 ***


Note You need to log in before you can comment on or make changes to this bug.