Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1333795 - Duplicated widgets in Dashboard
Summary: Duplicated widgets in Dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: 5.6.0
Assignee: Milan Zázrivec
QA Contact: Dmitry Misharov
URL:
Whiteboard: ui:dashboard
Depends On:
Blocks: 1356438
TreeView+ depends on / blocked
 
Reported: 2016-05-06 12:34 UTC by Dmitry Misharov
Modified: 2016-07-14 06:48 UTC (History)
6 users (show)

Fixed In Version: 5.6.0.8
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1356438 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:59:55 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the bug (deleted)
2016-05-06 12:34 UTC, Dmitry Misharov
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Dmitry Misharov 2016-05-06 12:34:35 UTC
Created attachment 1154613 [details]
Screenshot of the bug

Description of problem:
Dashboard allows to add several identical widgets.

Version-Release number of selected component (if applicable):
5.6.0.5-beta2.4.20160503153816_1fb554f 

How reproducible:
Always

Steps to Reproduce:
1. Go to Cloud Intel->Dashboard.
2. Add "Tenant Quotas" or "Hosts - Summary by Version" widgets.
3. Don't wait page reloading and add the same widget

Actual results:
After page reloading two identical widgets are in Dashboard.

Expected results:
Duplicating widgets is not allowed.

Additional info:
It's possible more than 2 widgets, just go on to add widgets before page will be reloaded. There is no this behavior in 5.5z

Comment 4 Milan Zázrivec 2016-05-13 09:55:35 UTC
https://github.com/ManageIQ/manageiq/pull/8680

Comment 5 CFME Bot 2016-05-17 14:00:54 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/9714a9a3e8e764f8e07b8422840b3fd6620f27a6

commit 9714a9a3e8e764f8e07b8422840b3fd6620f27a6
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Wed May 11 18:17:24 2016 +0200
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Mon May 16 21:21:10 2016 +0200

    Don't allow adding duplicate widgets into a dashboard
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1333795

 app/assets/javascripts/miq_application.js     |  2 +-
 app/controllers/dashboard_controller.rb       | 16 ++++++++++------
 spec/controllers/dashboard_controller_spec.rb | 24 ++++++++++++++++++++++++
 3 files changed, 35 insertions(+), 7 deletions(-)

Comment 6 Dmitry Misharov 2016-05-26 06:54:41 UTC
Verified fixed in 5.6.0.8-rc1.20160524155303_f2a5a50.

Comment 8 errata-xmlrpc 2016-06-29 15:59:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.