Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1332753 - possible memory leak in gamin
Summary: possible memory leak in gamin
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gamin
Version: 6.8
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-04 01:58 UTC by Joe Wright
Modified: 2018-09-25 22:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-15 19:11:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 2480791 None None None 2017-08-14 05:12:33 UTC

Description Joe Wright 2016-05-04 01:58:10 UTC
Description of problem:
- gam_server seems to be using a lot of heap space, hence, this may be a memory leak.

Version-Release number of selected component (if applicable):
- RHEL7 with kde
- gamin-0.1.10-16.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

from pmap -X:

17882:   /usr/libexec/gam_server
         Address Perm   Offset Device  Inode    Size     Rss     Pss Referenced Anonymous Swap Locked Mapping
        00400000 r-xp 00000000  fd:02 289996      84      40      40         40         0    0      0 gam_server
        00614000 r--p 00014000  fd:02 289996       4       4       4          4         4    0      0 gam_server
        00615000 rw-p 00015000  fd:02 289996       4       4       4          4         4    0      0 gam_server
        014f0000 rw-p 00000000  00:00      0 6382436 6382412 6382412    6381764   6382412    0      0 [heap]
    7fd782d99000 r-xp 00000000  fd:02 264160      88      56       0         56         0    0      0 libpthread-2.17.so
    7fd782daf000 ---p 00016000  fd:02 264160    2048       0       0          0         0    0      0 libpthread-2.17.so
    7fd782faf000 r--p 00016000  fd:02 264160       4       4       4          0         4    0      0 libpthread-2.17.so
...
    7ffd8ba51000 rw-p 00000000  00:00      0     148      28      28         20        28    0      0 [stack]
    7ffd8bacb000 r-xp 00000000  00:00      0       8       8       0          8         0    0      0 [vdso]
ffffffffff600000 r-xp 00000000  00:00      0       4       0       0          0         0    0      0 [vsyscall]
                                             ======= ======= ======= ========== ========= ==== ====== 
                                             6392544 6384024 6382830    6383348   6382540    0      0 KB 

6+ GB is rather large for this service
-----------------------------------------------------------------------

Comment 18 Ondrej Holy 2017-03-22 08:04:35 UTC
Let me know if this is still an issue with RHEL 6.9 (or patch from Bug 1399726).


Note You need to log in before you can comment on or make changes to this bug.