Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1331806 - cloud_init scripts not passing to fedora23 instance on RHOS7 provider
Summary: cloud_init scripts not passing to fedora23 instance on RHOS7 provider
Keywords:
Status: CLOSED DUPLICATE of bug 1355895
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: 5.6.0
Assignee: Brandon Dunne
QA Contact: luke couzens
URL:
Whiteboard: cloud_init:openstack
: 1346432 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-29 14:52 UTC by luke couzens
Modified: 2016-08-30 13:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-30 13:06:11 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description luke couzens 2016-04-29 14:52:55 UTC
Description of problem:cloud_init scripts failing to run when provisioning new fedora23 instance on rhos7 provider.

Version-Release number of selected component (if applicable):5.6.0.4-beta2.3


How reproducible:100%


Steps to Reproduce:
1.provision 5.6.0.4-beta2.3 appliance
2.add rhos7 provider
3.provision fedora23 with cloud init script

Actual results: vm created but no scripts run


Expected results:vm created and script run


Additional info: scripts tested with 

#cloud-config
write_files:
  - path: /tmp/test.txt
    content: |
      Here is a line.

#cloud-config
hostname: mynode
fqdn: mynode.example.com
manage_etc_hosts: true

running the same test on a 5.5.3.4 appliance works fine.

Comment 2 Greg McCullough 2016-06-23 13:26:11 UTC
*** Bug 1346432 has been marked as a duplicate of this bug. ***

Comment 3 Brandon Dunne 2016-07-25 18:51:11 UTC
Please retest since https://bugzilla.redhat.com/show_bug.cgi?id=1355895 has been resolved.

Comment 4 Brandon Dunne 2016-08-22 18:31:18 UTC
Luke, Can this be marked as duplicate?

Comment 5 luke couzens 2016-08-30 13:06:11 UTC
Brandon, I believe so as its works correctly on 5.6.1.2 so either dup or verified.

*** This bug has been marked as a duplicate of bug 1355895 ***


Note You need to log in before you can comment on or make changes to this bug.