Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1328455 - [cjdns] Make it nodejs_arches exclusive
Summary: [cjdns] Make it nodejs_arches exclusive
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cjdns
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stuart D Gathman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker PPCTracker F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2016-04-19 12:32 UTC by Rafael Fonseca
Modified: 2016-05-18 03:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-18 03:19:00 UTC


Attachments (Terms of Use)
Make cjdns exclusive to nodejs arches (deleted)
2016-04-19 12:32 UTC, Rafael Fonseca
no flags Details | Diff

Description Rafael Fonseca 2016-04-19 12:32:30 UTC
Created attachment 1148545 [details]
Make cjdns exclusive to nodejs arches

Description of problem: nodejs is only available to some platforms. Since cjdns depends on it, it should be marked as ExclusiveArch: %{nodejs_arches}.


Version-Release number of selected component (if applicable): 17.3.12


How reproducible: always


Steps to Reproduce: ppc-koji build cjdns.


Additional info: please, apply attached patch on all relevant versions.

Comment 1 Stuart D Gathman 2016-05-18 03:19:00 UTC
nodejs is actually available on ppc on upstream.

But I've added the ExclusiveArch, and hopefully when ppc nodejs makes it into Fedora, that will be updated.  

Sorry, I lost your credit (newbie package maintainer), but I added it back to master, so should be in release 14.

The ExclusiveArch is in 17.3-13, and in earlier releases for EPEL.


Note You need to log in before you can comment on or make changes to this bug.