Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 132840 - Issue with NPTL and e-d-s copy of libdb
Summary: Issue with NPTL and e-d-s copy of libdb
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Update
TreeView+ depends on / blocked
 
Reported: 2004-09-17 18:28 UTC by Dave Malcolm
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-24 01:51:50 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2004-09-17 18:29:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
If e-d-s is built on a machine which supports NPTL (which covers all
our build machines), then the included copy of libdb requires NPTL.

Unfortunately, if the resulting package is run on a machine which
doesn't support NPTL (which can be simulated by setting
LD_ASSUME_KERNEL=2.4.19 , or any value below 2.4.20 based on how our
glibc is set up), then the attempt to call env->open in
addressbook/backends/file/e-book-backend-file.c will fail,
and you get a "Error Loading Addressbook" dialog.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. export LD_ASSUME_KERNEL=2.4.19
2. ensure e-d-s isn't running (watch out for panel clocks)
3. restart evolution within this environment, try to open local
addressbook
    

Actual Results:  "Error Loading Addressbook" dialog

Expected Results:  Should be able to open it.

Additional info:

Comment 1 Dave Malcolm 2004-09-17 18:52:30 UTC
132236 is a possible duplicate of this

Comment 2 Dave Malcolm 2004-09-17 19:14:21 UTC
For a possible fix, see:
http://toshok.org/libdb-pthread-patch.diff

Comment 3 Dave Malcolm 2004-09-20 19:10:14 UTC
See also: http://bugzilla.ximian.com/show_bug.cgi?id=65996

Comment 5 Dave Malcolm 2005-08-24 01:51:50 UTC
Is this actually affecting anyone?  I'm going to close this as WONTFIX, if
anyone's getting bitten by this, feel free to reopen it.


Note You need to log in before you can comment on or make changes to this bug.