Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1328078 - *2pcscmd commands ought not to suggest "pcs cluster cib <file> --config" that doesn't currently work for subsequent local-modification pcs commands
Summary: *2pcscmd commands ought not to suggest "pcs cluster cib <file> --config" that...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: clufter
Version: 6.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Pokorný [poki]
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On: 1359057 1328066
Blocks: 1343661 1367536
TreeView+ depends on / blocked
 
Reported: 2016-04-18 11:50 UTC by Jan Pokorný [poki]
Modified: 2017-03-21 11:07 UTC (History)
10 users (show)

Fixed In Version: clufter-0.59.7-1.el6
Doc Type: No Doc Update
Doc Text:
With *2pcscmd* commands, clufter no longer suggests "pcs cluster cib <file> --config" that doesn't currently work for subsequent local-modification pcs commands (which is the purpose together with sequence-crowning cib-push in this context), so rather use mere "pcs cluster cib <file>".
Clone Of: 1328066
Environment:
Last Closed: 2017-03-21 11:07:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0716 normal SHIPPED_LIVE clufter bug fix update 2017-03-21 12:41:28 UTC

Description Jan Pokorný [poki] 2016-04-18 11:50:16 UTC
Fix: s/pcs cluster cib <file> --config/pcs cluster cib <file>/


+++ This bug was initially created as a clone of Bug #1328066 +++

Comment 2 Jan Pokorný [poki] 2016-04-18 16:20:52 UTC
Fix is as simple as (next branch):
https://pagure.io/clufter/dad09c9e8172d44fea87822e9a51d8e0d3bae370

Comment 3 Miroslav Lisik 2016-04-18 17:06:33 UTC
Version: clufter-cli-0.56.2-1.el6

How to reproduce:

1. Create cluster and wait until it is started.

[root@virt-263 ~]# pcs cluster auth virt-263 virt-267 virt-274
Username: hacluster
Password: 
virt-267: Authorized
virt-274: Authorized
virt-263: Authorized
[root@virt-263 ~]# pcs cluster setup --start --name Cluster virt-263 virt-267 virt-274
Destroying cluster on nodes: virt-263, virt-267, virt-274...
virt-274: Stopping Cluster (pacemaker)...
virt-267: Stopping Cluster (pacemaker)...
virt-263: Stopping Cluster (pacemaker)...
virt-274: Successfully destroyed cluster
virt-267: Successfully destroyed cluster
virt-263: Successfully destroyed cluster

Sending cluster config files to the nodes...
virt-263: Updated cluster.conf...
virt-267: Updated cluster.conf...
virt-274: Updated cluster.conf...

Starting cluster on nodes: virt-263, virt-267, virt-274...
virt-267: Starting Cluster...
virt-263: Starting Cluster...
virt-274: Starting Cluster...

Synchronizing pcsd certificates on nodes virt-263, virt-267, virt-274...
virt-267: Success
virt-274: Success
virt-263: Success

Restarting pcsd on the nodes in order to reload the certificates...
virt-267: Success
virt-263: Success
virt-274: Success

[root@virt-263 ~]# pcs status
Cluster name: Cluster
WARNING: no stonith devices and stonith-enabled is not false
Last updated: Mon Apr 18 18:56:51 2016          Last change: Mon Apr 18 18:56:30 2016 by root via crmd on virt-263
Stack: cman
Current DC: virt-263 (version 1.1.14-8.el6-70404b0) - partition with quorum
3 nodes and 0 resources configured

Online: [ virt-263 virt-267 virt-274 ]

Full list of resources:


PCSD Status:
  virt-263: Online
  virt-267: Online
  virt-274: Online

2. Get the cluster cib like the clufter does (using --config option):

[root@virt-263 ~]# pcs cluster cib tmp-cib.xml --config
[root@virt-263 ~]# cat tmp-cib.xml
<configuration>
  <crm_config>
    <cluster_property_set id="cib-bootstrap-options">
      <nvpair id="cib-bootstrap-options-have-watchdog" name="have-watchdog" value="false"/>
      <nvpair id="cib-bootstrap-options-dc-version" name="dc-version" value="1.1.14-8.el6-70404b0"/>
      <nvpair id="cib-bootstrap-options-cluster-infrastructure" name="cluster-infrastructure" value="cman"/>
    </cluster_property_set>
  </crm_config>
  <nodes>
    <node id="virt-263" uname="virt-263"/>
    <node id="virt-274" uname="virt-274"/>
    <node id="virt-267" uname="virt-267"/>
  </nodes>
  <resources/>
  <constraints/>
</configuration>

3. Perform an action on this file with pcs:

[root@virt-263 ~]# pcs -f tmp-cib.xml resource create dummy Dummy
Error: unable to get cib
Error: unable to get cib
[root@virt-263 ~]# echo $?
1

Comment 5 Jan Pokorný [poki] 2016-04-20 10:58:39 UTC
Note that in [comment 3], sequence akin to (buggy) clufter-emitted output
in a form of pcs commands (~ shell script) is exercised to demonstrate
the issue.

Once it's corrected = last switch in "pcs cluster cib <file> --config"
is stripped (see [comment 2]), a non-bumpy (not manual intervention
imposing) ride is restored.

For posterity, this got broken as of
https://pagure.io/clufter/0ebae339774aeb18b8fc0cd80768ba7dc4940bff
(first released in v0.50.4, hence RHEL 7.2 [and only] is also affected).

Comment 7 Jan Pokorný [poki] 2016-10-10 12:59:59 UTC
Note this is addressed in RHEL 7.3 through rebase ([bug 1343661]).

Comment 12 errata-xmlrpc 2017-03-21 11:07:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0716.html


Note You need to log in before you can comment on or make changes to this bug.