Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 132340 - IIIMF causes gnome-ssh-askpass to fail closing
Summary: IIIMF causes gnome-ssh-askpass to fail closing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: IIIMF
TreeView+ depends on / blocked
 
Reported: 2004-09-11 02:53 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-25 14:58:26 UTC


Attachments (Terms of Use)

Description Warren Togami 2004-09-11 02:53:49 UTC
Description of problem:
gnome-ssh-askpass fails to terminate when launched before
gnome-session during login.  When using the below configuration, this
causes login to get stuck because gnome-session is never launched.

[warren@ibmlaptop ~]$ cat .Xclients-default
ssh-add < /dev/null
exec gnome-session
[warren@ibmlaptop ~]$ set |grep LANG
GDM_LANG=en_US.UTF-8
LANG=en_US.UTF-8

warren    4402  4345  0 16:36 ?        00:00:00 ssh-add
warren    4403  4402  0 16:36 ?        00:00:00 [gnome-ssh-askpa]
<defunct>
warren    4405     1  0 16:36 ?        00:00:00
com.OpenI18N.leif.CannaLE.menu

Manually killing these processes allows gnome-session to run.

However "ssh-add < /dev/null" when run from a terminal does not
exhibit this problem.

Version-Release number of selected component (if applicable):
im-sdk-12.0.1-6.svn1891
openssh-askpass-gnome-3.9p1-3

Comment 1 Warren Togami 2004-09-12 00:50:40 UTC
It has something to do with the parent process of
com.OpenI18N.leif.CannaLE.menu being 1 (init)?  When gnome-ssh-askpass
is launched from a terminal, the parent process is never 1.

Comment 2 Warren Togami 2004-09-19 03:09:17 UTC
This seems to have been fixed by something recently.  Keep in MODIFIED
state for now until it is confirmed.

Comment 3 Warren Togami 2004-09-20 05:35:21 UTC
Hmm, I was wrong.  It happened again today.


Comment 4 Yu Shao 2004-10-05 03:57:14 UTC
Hi Warren, do you still see this bug?

Comment 5 Warren Togami 2004-10-05 04:23:37 UTC
It seems to trigger only when there are existing defunct auxmenu
processes.  Perhaps related to Bug 134304?

Comment 6 Akira TAGOH 2004-10-06 13:59:37 UTC
please test 12.0.1-13.svn1943. if it's related realizing auxmenu, it's
no longer realized until you activate the IM.

Comment 7 Warren Togami 2004-10-25 14:58:26 UTC
This has been good in 12.1-1 for a long time.


Note You need to log in before you can comment on or make changes to this bug.