Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1322729 - Hosted-engine-setup still requires to copy the answerfile from the first host via scp
Summary: Hosted-engine-setup still requires to copy the answerfile from the first host...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 1.3.5.0
Hardware: Unspecified
OS: Unspecified
high
unspecified vote
Target Milestone: ovirt-3.6.6
: 1.3.6.1
Assignee: Simone Tiraboschi
QA Contact: sefi litmanovich
URL:
Whiteboard:
: 1334920 (view as bug list)
Depends On:
Blocks: RHEV-RHCI 1330523
TreeView+ depends on / blocked
 
Reported: 2016-03-31 08:46 UTC by Simone Tiraboschi
Modified: 2017-05-11 09:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-30 10:52:03 UTC
oVirt Team: Integration
rule-engine: ovirt-3.6.z+
mgoldboi: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 42224 master MERGED packaging: setup: avoid copying answerfile over scp 2016-04-13 10:30:36 UTC
oVirt gerrit 55503 ovirt-hosted-engine-setup-1.3 MERGED packaging: setup: avoid copying answerfile over scp 2016-04-14 09:27:56 UTC
oVirt gerrit 55525 master ABANDONED setup: reload CA subject after host-deploy 2016-08-23 08:51:10 UTC
oVirt gerrit 55545 ovirt-hosted-engine-setup-1.3 ABANDONED setup: reload CA subject after host-deploy 2016-08-23 08:50:51 UTC
oVirt gerrit 56823 master MERGED storage: get rid of StorageEnv.STORAGE_TYPE 2016-04-29 05:53:15 UTC
oVirt gerrit 56825 ovirt-hosted-engine-setup-1.3 MERGED storage: get rid of StorageEnv.STORAGE_TYPE 2016-04-29 05:53:57 UTC

Description Simone Tiraboschi 2016-03-31 08:46:01 UTC
Description of problem:
Hosted-engine-setup still requires to copy the answerfile from the first host via scp while it could be avoided since on 3.6 the answerfile is already on the shared storage.

Version-Release number of selected component (if applicable):
1.3.5.0

How reproducible:
100%

Steps to Reproduce:
1. Deploy an additional hosted-engine host
2.
3.

Actual results:
It asks to copy the answerfile from another host

Expected results:
It just consume the answerfile on the shared storage

Additional info:
Avoiding the scp copy helps on unattended or automated flow and in the integration with other products.

Comment 1 Sandro Bonazzola 2016-03-31 09:06:56 UTC
Simone, will migration from 3.5 to 4.0 be affected by this? Maybe we should keep scp around and just don't use it if we have the answer file on shared storage.

Comment 2 Simone Tiraboschi 2016-03-31 09:39:58 UTC
Currently it's already not possible (and we are explicitly preventing it) to add a 3.6 host while the other HE hosts are at 3.5 since the new additional 3.6 host will expect to found vm.conf on the shared storage and it's created there just:
- deploying from scratch on 3.6
- uprading one host from 3.5 to 3.6

Comment 3 sefi litmanovich 2016-05-08 12:10:18 UTC
Verified with ovirt-hosted-engine-setup-1.3.6.1-1.el7ev.noarch.

1. Ran ovirt-hosted-engine-setup on first host, created vm with appliance and installed engine successfully.
2. Ran ovirt-hosted-engine-setup on second host to add to new HE.
During setup I get:

          --== SYSTEM CONFIGURATION ==--
         
[WARNING] A configuration file must be supplied to deploy Hosted Engine on an additional host.
[ INFO  ] Answer file successfully loaded

answer files was fetched from shared storage as expected.

Comment 4 Simone Tiraboschi 2016-05-17 21:01:31 UTC
*** Bug 1334920 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.