Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1321 - Samba 2.0.2 permissions
Summary: Samba 2.0.2 permissions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-24 22:14 UTC by ta.honermann
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-21 22:21:55 UTC


Attachments (Terms of Use)

Description ta.honermann 1999-02-24 22:14:41 UTC
I'm not sure if this is a bug with Samba/the Samba RPM for
RedHat 5.2/RedHat 5.2/ or just a net admin permissions
issue, but...

I'm trying to setup a RedHat 5.2 Kernel 2.0.36 Intel box
with the Samba 2.0.2 RPMs RedHat distributes on the
"Upgrading to the 2.2.x Linux Kernel on RedHat 5.2 Linux
systems" page.  I have setup this machine to be a domain
member, which seemed to work fine, however I can't
authenticate to it via the domain.  When a client tries to
attach I get the following in the log file for that client

	/var/log/samba/log.uwh23bd799

[1999/02/24 14:58:59, 0] smbd/uid.c:become_gid(105)
  Couldn't set effective gid to 100 currently set to
(real=0,eff=0)
[1999/02/24 14:58:59, 0] smbd/service.c:make_connection(425)
  Can't become connected user!
[1999/02/24 14:58:59, 0] smbd/uid.c:become_gid(105)
  Couldn't set effective gid to 100 currently set to
(real=0,eff=0)
[1999/02/24 14:58:59, 0] smbd/service.c:make_connection(425)
  Can't become connected user!

The client is a Windows 95 OSR2.1 workstation.

Comment 1 gte855f 1999-03-06 00:17:59 UTC
smbmount and smbumount are not shipped setuid.  I believe the previous
versions were?  Or maybe they did not have to be setuid root to work
for non root users.

Comment 2 Bill Nottingham 1999-03-08 18:47:59 UTC
AFAICR, smb(u)mount were never shipped setuid.
If the sysadmin of a system wants to allow a user
to mount shares, he can make them setuid. In any
case, I doubt that that's what the message is from.

Comment 3 Bill Nottingham 1999-03-16 00:14:59 UTC
what are uid/gid 100 on your system?

Comment 4 ta.honermann 1999-03-16 20:16:59 UTC
OK, I downloaded the source to Samba and recompiled it on my machine.
 I copied the newly compiled smbd & nmbd over the ones installed by
the RedHat Samba 2.0.2 and kept all the other files installed by the
RedHat Samba 2.0.2 and everything works fine.  The compiled smbd &
nmbd that RedHat is distributing does not work correctly on my
machine.

Comment 5 Bill Nottingham 1999-03-17 16:41:59 UTC
can you check and see what are the permissions on smbd/nmbd you just
compiled?

Comment 6 ta.honermann 1999-03-17 17:08:59 UTC
ls -l /usr/sbin/smbd
-rwxr-xr-x   1 root     root       740705 Feb 24 19:26 /usr/sbin/smbd*
ls -l /usr/sbin/nmbd
-rwxr-xr-x   1 root     root       365806 Feb 24 19:26 /usr/sbin/nmbd*

Comment 7 Bill Nottingham 1999-03-19 22:01:59 UTC
what options did you pass to configure when you
compiled it?

Comment 8 ta.honermann 1999-03-19 22:56:59 UTC
None.  I just ran configure, changed the Makefile for the directories
that RedHat uses (/etc/smbpasswd instead of /usr/local/samba...), ran
make and then copied smbd and nmbd to the new locations.

Comment 9 Bill Nottingham 1999-03-22 16:53:59 UTC
Hm. I still can't reproduce this here. Could you try rebuilding
the source RPM from Raw Hide/Starbuck (samba-2.0.3-*) and
see if that works for you?

Comment 10 ta.honermann 1999-03-22 17:22:59 UTC
Possibly, it will take me a while to get around to it.  I haven't
tried samba-2.0.3 yet, maybe that will fix things on its own.  Right
now things are working fine so I don't have much of an incentive to
work on this unless other people are having the same problem.

Comment 11 Bill Nottingham 1999-03-22 17:48:59 UTC
OK. I'm going to close this bug until we can see if the changes
persist, or someone else can duplicate it.

Comment 12 ta.honermann 1999-03-22 17:52:59 UTC
OK

Comment 13 Bill Nottingham 1999-07-21 22:21:59 UTC
This came about due to an autoconf test that succeeded because
our build machine was *running* a 2.2 kernel, even though we
compiled against a 2.0.... Bleah.

This will be fixed with the samba-2.0.5 RPMs, which will be available
RSN.


Note You need to log in before you can comment on or make changes to this bug.