Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1320 - kibitz fails: does not find 'write'
Summary: kibitz fails: does not find 'write'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
: 2026 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-24 20:23 UTC by benno
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-08 20:26:37 UTC


Attachments (Terms of Use)

Description benno 1999-02-24 20:23:49 UTC
Hi,
kibitz fails because it can not execute /bin/write
which on redhat lives in /usr/bin/write
please fix the path in the kibitz executable.

regards,
Benno.

Comment 1 David Lawrence 1999-02-25 21:12:59 UTC
I have verified this behaviour in our test lab. The path to the write
executable is indeed incorrect.
This has been assigned to a developer.

Comment 2 David Lawrence 1999-02-25 21:14:59 UTC
kibitz belongs to the expect package while the write executable
belongs to util-linux so therefore I hasve assigned it to the owner of
the util-linux package.

Comment 3 Jeff Johnson 1999-03-18 15:12:59 UTC
The path needs to be changed in expect.

Comment 4 Jeff Johnson 1999-04-07 18:11:59 UTC
*** Bug 2026 has been marked as a duplicate of this bug. ***

The kibitz script, which is a part of expect, has the path
to the write program hard-coded as /bin/write.  write is
actually found in /usr/bin/write, so kibitz breaks unless
/usr/bin/write is symlinked to /bin/write (or the script
is changed).  Using expect-5.26-20 and util-linux-2.8-11,
kibitz prints "sh: /bin/write: no such file or directory".
(I'm submitting this as a util-linux bug, though it's
really an expect bug, because there is no category for
expect bugs.)

Comment 5 Jeff Johnson 1999-04-08 20:26:59 UTC
Path changed to /usr/bin/write in tcltk-8.0.4-29.


Note You need to log in before you can comment on or make changes to this bug.