Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 131549 - Evoluation Cal does not allow Cut and Paste
Summary: Evoluation Cal does not allow Cut and Paste
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On: 167157
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-09-02 07:15 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-27 19:57:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 265440 None None None Never

Description Lawrence Lim 2004-09-02 07:15:05 UTC
Description of problem:
Cut and Paste an entry in the time slot, allows the entry to be remove
from the time slot but it does not allow pasting. Hence, Ctrl-X works
but Ctrl-V does not. 

However, Copy and Paste a hightlighted an entry in the time slot
allows the entry to be pasted to a new time slot. So Ctrl-C and Ctrl-V
works.

Version-Release number of selected component (if applicable):
- evolution-data-server-0.0.97-2
- evolution-1.5.92.2-2

How reproducible:
Always

Steps to Reproduce:
1.Start Evolution Cal
2.Create an appointment
3.Click on the time slot of the appointment created (will see a
blinking cursor)
4.Hightlight the entry by using shift+home or shift+end
5.Ctrl-X then Ctrl-V 
  
Actual results:
Cut is good but paste is not

Expected results:
Cut and paste should work

Additional info:
Affect all locale including en_US

Comment 1 Lawrence Lim 2004-09-07 08:14:40 UTC
Bug filed upstream.

http://bugzilla.ximian.com/show_bug.cgi?id=65440

Comment 2 Dave Malcolm 2005-01-20 22:01:17 UTC
Need to be in Day View to reproduce.

"Paste" on right-click context menu seems to work (pasting to the time
selected when the rightclick occurs), it's the Ctrl-V keyboard
shortcut that seems broken (also the main menu Edit->Paste item is
insensitive); these fail to work even if you have a blank timeslot
selected.

Arguably either (i) when you do a cut with text selected, it should
cut the text, leaving the appointment behind.  Currently the whole
appointment is cut.
or (ii) should allow Ctrl-V and main menu Edit->Paste, provided you
have a selected timeslot (or maybe even paste to last location)

Comment 4 Leon Ho 2005-04-11 06:16:27 UTC
Still happening on:
evolution-2.2.1.1-2
evolution-data-server-1.2.1-1


Comment 5 Lawrence Lim 2005-04-15 05:07:06 UTC
<http://bugzilla.gnome.org/show_bug.cgi?id=265440>

Recent Comments:

C Shilpa changed:                             
Target Milestone|2.3
------- Additional Comments From C Shilpa  2005-04-14 23:40 -------
Open the new appointment window which pops up. Now try to paste whatever was
cutin the summary field. It pastes it in the form of a .ics file with all the
BEGINand END, etc. I have tried it in evolution 2.2.1 on Suse 9.3 RC1.


Comment 7 Lawrence Lim 2005-08-24 00:04:04 UTC
Noticed has mentioned that this bug is fixed.


<http://bugzilla.gnome.org/show_bug.cgi?id=265440>
------- Additional Comments From chenthill  2005-08-23 14:01 -------
It works properly with the latest versions.


Comment 8 Akira TAGOH 2005-09-28 09:16:56 UTC
Confirming this resolution is hard due to Bug#167157. after restarting
evolution, I can see the duplicated (copied) appointment though.

Comment 9 Ray Strode [halfline] 2006-01-27 19:57:13 UTC
great, closing...


Note You need to log in before you can comment on or make changes to this bug.