Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1315266 - Capsule stops listening on 9090 after log rotate
Summary: Capsule stops listening on 9090 after log rotate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule
Version: 6.1.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent vote
Target Milestone: Unspecified
Assignee: Dmitri Dolguikh
QA Contact: Chris Duryee
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1273785
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2016-03-07 11:53 UTC by Brad Buckingham
Modified: 2019-04-01 20:26 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1273785
Environment:
Last Closed: 2016-07-27 09:25:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2462131 None None None 2016-10-03 21:50:23 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Comment 2 Bryan Kearney 2016-03-09 15:11:58 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 3 Bryan Kearney 2016-03-09 15:12:02 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 4 Bryan Kearney 2016-03-17 14:12:08 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12295 has been closed
-------------
Anonymous
Applied in changeset commit:7cc71a107f37f1c7dfc12f2791906565e796bed6.

Comment 5 Chris Duryee 2016-03-24 19:02:57 UTC
how I verified:

* confirmed foreman-proxy was running, and that ruby was listening on port 9090 with netstat
* ran logrotate -f /etc/logrotate.conf
* confirmed foreman-proxy was still running, that ruby was listening on 9090, and the pid was different

Comment 8 errata-xmlrpc 2016-07-27 09:25:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.