Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1310800 - systemd-229-1.fc24 build failure on ppc64
Summary: systemd-229-1.fc24 build failure on ppc64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Synacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1310617 (view as bug list)
Depends On:
Blocks: ARM64, F-ExcludeArch-aarch64 F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2016-02-22 16:54 UTC by Ngo Than
Modified: 2016-02-23 10:49 UTC (History)
9 users (show)

Fixed In Version: systemd-229-3.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-23 10:49:41 UTC


Attachments (Terms of Use)

Description Ngo Than 2016-02-22 16:54:02 UTC
SKIP: test-bus-creds
SKIP: test-bus-gvariant
FAIL: test-event
./build-aux/test-driver: line 107:  1408 Aborted                 (core dumped) "$@" > $log_file 2>&1
PASS: test-netlink
PASS: test-local-addresses
PASS: test-resolve
PASS: test-dhcp-option
PASS: test-dhcp-client
SKIP: test-dhcp-server
PASS: test-ipv4ll

for more infos please take a look at http://ppc.koji.fedoraproject.org/kojifiles/work/tasks/4846/3154846/build.log

i will provide the backtrace later

Comment 1 Zbigniew Jędrzejewski-Szmek 2016-02-22 20:54:18 UTC
This is already fixed upstream:
https://github.com/systemd/systemd/commit/32c1f5a57998f2a9e1992af006b83e39e3155830

Comment 2 Ngo Than 2016-02-22 23:23:15 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #1)
> This is already fixed upstream:
> https://github.com/systemd/systemd/commit/
> 32c1f5a57998f2a9e1992af006b83e39e3155830

it's the same bug like https://github.com/systemd/systemd/issues/2597
and confirmed that the commit fixes the crash.

Zbigniew, can we get the fixes applied in the rawhide package?

Thanks

Comment 3 Jan Synacek 2016-02-23 07:47:34 UTC
*** Bug 1310617 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.