Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 130853 - system-config-keyboard does not allow for the selection of any Indic keyboard layouts
Summary: system-config-keyboard does not allow for the selection of any Indic keyboard...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-keyboard
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: Indic FC4Target 158139
TreeView+ depends on / blocked
 
Reported: 2004-08-25 10:23 UTC by Jatin Nansi
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-18 19:49:32 UTC


Attachments (Terms of Use)

Description Jatin Nansi 2004-08-25 10:23:42 UTC
Description of problem:
If a user for any Indic language wishes to switch the keyboard layout
to that of his language, it cannot be done thru system-config-keyboard. 
It is not possible to select multiple keyboard layouts using this applet. 


Version-Release number of selected component (if applicable):
0.145


How reproducible:
Every time


Steps to Reproduce:
1. Run system-config-keyboard as root
2.
3.
  

Actual results:
- Cannot switch to any indic keyboard layout (no options available)
- Cannot select multiple layouts


Expected results:
- should be able to select indic keyboard layouts
- should be able to select multiple layouts


Additional info:
Currently, there are no indic keyboard layouts available to select in
system-config-keyboard.
Multiple layout selection is essential for indic languages, since all
indic users switch between indic and english very often. 
All of these capabilities are available in the keyboard applet of
gnome preferences.

Comment 1 Jeremy Katz 2004-08-25 15:10:24 UTC
Keyboard layouts where you regularly switch between one and English
automatically get English added as a secondary layout when they're
added to system-config-keyboard.

And adding more requires knowing exactly which ones to add and work.

Comment 2 Jatin Nansi 2004-08-30 02:58:19 UTC
These are the layouts to be added:

Bengali (Inscript):    ben
Bengali (Probhat):     ben(probhat)
Devanagari (Inscript): dev
Gujarati (Inscript):   guj
Punjabi (Inscript):    gur
Tamil (Inscript):      tml(INSCRIPT)
Tamil (Typewriter):    tml(UNI)

Pass the option on the right to setxkbmap to set the keyboard to the
layout name on left.
When doing this on the shell prompt, you need to quote the parameters.
All of these layouts should have English as the secondary layout.

Comment 3 Jeremy Katz 2004-08-30 15:34:10 UTC
Paul, can you add these to the list of keyboard models in
rhpl/src/keyboard_models.py?

Comment 7 Paul Nasrat 2004-09-13 07:50:30 UTC
Commited to CVS.  Will require rhpl release

Comment 8 Jatin Nansi 2004-10-07 04:56:50 UTC
Confirming that the layouts are added to s-c-keyboard. However, i am
unable to switch b/w the 2 layouts, ie. us & corresponding indic. 
The toggle option is not getting set. 

This is the output when trying to set layout to gujarati.
[root@dhcp-192 ~]# system-config-keyboard
cannot open file guj
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'us,guj', '-model',
'pc105', '-option', '']
[root@dhcp-192 ~]# 

This is the output when setting layout to greek:
[root@dhcp-192 ~]# system-config-keyboard
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'us,el', '-model',
'pc105', '-option', 'grp:shift_toggle,grp_led:scroll']
[root@dhcp-192 ~]# 

While this works just fine: 
setxkbmap -layout us,guj -model pc105 -option
grp:shift_toggle,grp_led:scroll

Here i can toggle between US and devanagari layouts by pressing the
shift keys together.

This does not work for any of the indic languages.

Comment 9 Paul Nasrat 2004-10-07 09:41:31 UTC
Apologies, that's fixed for both Indic and Arabic keyboards.

Comment 10 Jatin Nansi 2004-10-28 09:59:17 UTC
Confirmed fixed for 4 out of 5 languages. Punjabi (Inscript) still has
the above problem (option shift_toggle not set). Tested on
rawhide-20041024.

Comment 15 Paul Nasrat 2005-05-17 16:05:26 UTC
Should be in rawhide - rhpl 0.163-1 and should make fc4



Note You need to log in before you can comment on or make changes to this bug.