Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1308252 - xfsprogs: FTBFS in rawhide
Summary: xfsprogs: FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xfsprogs
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Sandeen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1307964 (view as bug list)
Depends On: 1305512
Blocks: PPCTracker F24FTBFS F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2016-02-13 22:42 UTC by Fedora Release Engineering
Modified: 2016-03-11 16:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-11 04:32:19 UTC


Attachments (Terms of Use)
build.log (deleted)
2016-02-13 22:42 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2016-02-13 22:42 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2016-02-13 22:42 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2016-02-13 22:42:49 UTC
Your package xfsprogs failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12879193

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

Comment 1 Fedora Release Engineering 2016-02-13 22:42:51 UTC
Created attachment 1126824 [details]
build.log

Comment 2 Fedora Release Engineering 2016-02-13 22:42:52 UTC
Created attachment 1126825 [details]
root.log

Comment 3 Fedora Release Engineering 2016-02-13 22:42:53 UTC
Created attachment 1126826 [details]
state.log

Comment 4 Cole Robinson 2016-02-14 02:31:10 UTC
*** Bug 1307964 has been marked as a duplicate of this bug. ***

Comment 5 Cole Robinson 2016-02-14 02:32:00 UTC
This is the fsxattr issue, bug 1305512

Comment 6 Jan Kurik 2016-02-24 15:19:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 7 Eric Sandeen 2016-02-26 13:43:25 UTC
This will be fixed when xfsprogs-4.5.0 is released, which should be fairly soon now.  I don't really want to cherry pick fixes when a proper release will do the trick in short order.  If it becomes more urgent let me know, and I can pursue other options.

-Eric

Comment 8 Upstream Release Monitoring 2016-03-11 04:12:05 UTC
sandeen's xfsprogs-4.3.0-2.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=743829

Comment 9 Eric Sandeen 2016-03-11 04:32:19 UTC
Fixed in rawhide & f24.

Comment 10 Eric Sandeen 2016-03-11 16:50:37 UTC
Thanks, sorry - missed ;)


Note You need to log in before you can comment on or make changes to this bug.