Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1306793 - emacs build failure for ppc64le "Program segment above .bss"
Summary: emacs build failure for ppc64le "Program segment above .bss"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jan Synacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1306949 (view as bug list)
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2016-02-11 17:45 UTC by Michel Normand
Modified: 2016-02-15 12:31 UTC (History)
7 users (show)

Fixed In Version: emacs-24.5-10.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-15 09:51:32 UTC


Attachments (Terms of Use)
emacs-24-0010-ELF-unexec-Correct-section-header-index.patch (deleted)
2016-02-15 07:28 UTC, Michel Normand
no flags Details | Diff
emacs-24-0011-ELF-unexec-Tidy-code.patch (deleted)
2016-02-15 07:29 UTC, Michel Normand
no flags Details | Diff
emacs-24-0012-ELF-unexec-Merge-Alpha-and-MIPS-COFF-debug-handling.patch (deleted)
2016-02-15 07:30 UTC, Michel Normand
no flags Details
emacs-24-0013-ELF-unexec-Symbol-table-patching.patch (deleted)
2016-02-15 07:30 UTC, Michel Normand
no flags Details
emacs-24-0014-ELF-unexec-_OBJC_-symbols-in-bss-sections.patch (deleted)
2016-02-15 07:31 UTC, Michel Normand
no flags Details | Diff
emacs-24-0015-ELF-unexec-R_-_NONE-relocs.patch (deleted)
2016-02-15 07:31 UTC, Michel Normand
no flags Details | Diff
emacs-24-0016-ELF-unexec-Drive-from-PT_LOAD-header-rather-than-sec.patch (deleted)
2016-02-15 07:32 UTC, Michel Normand
no flags Details | Diff
emacs-24-0017-ELF-unexec-Don-t-insert-a-new-section.patch (deleted)
2016-02-15 07:33 UTC, Michel Normand
no flags Details | Diff
emacs-24-0018-src-unexelf.c-NEW_PROGRAM_H-Remove-unused-macro-Bug-.patch (deleted)
2016-02-15 07:33 UTC, Michel Normand
no flags Details | Diff
emacs-24-0019-ELF-unexec-align-section-header.patch (deleted)
2016-02-15 07:34 UTC, Michel Normand
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1271294 None None None Never

Internal Links: 1271294

Description Michel Normand 2016-02-11 17:45:51 UTC
Description of problem: emacs failure with last binutils 2.28

as reported by Robinson in 
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=312728
===
...
Loading /builddir/build/BUILD/emacs-24.5/lisp/tooltip.el (source)...
Finding pointers to doc strings...
Finding pointers to doc strings...done
Dumping under the name emacs
emacs: Program segment above .bss in /builddir/build/BUILD/emacs-24.5/build-gtk/src/temacs
Makefile:815: recipe for target 'bootstrap-emacs' failed
===

probably similar to
https://www.mail-archive.com/debian-bugs-rc@lists.debian.org/msg410864.html

Version-Release number of selected component (if applicable): rawhide


How reproducible: koji build for ppc64le archi


Additional info:

I validate a set of patches in 
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3127419

Comment 1 Michel Normand 2016-02-11 18:14:38 UTC
(In reply to Michel Normand from comment #0)
> Description of problem: emacs failure with last binutils 2.28
> 
> as reported by Robinson in 
> http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=312728

oups wrong url, correct one is:
  http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3127290

Comment 3 Peter Robinson 2016-02-12 08:01:41 UTC
(In reply to Jan Synacek from comment #2)
> Possibly fixed by
> http://git.savannah.gnu.org/cgit/emacs.git/commit/
> ?id=0d6442265e5b709af5eebedf8f0d6b82974f4c31.

Can you scratch build it to test on PPC "ppc-koji build --scratch f24 blah.src.rpm" and get something pushed, this is blocking a large part of the mass rebuild on PPC. thanks

Comment 4 Jan Synacek 2016-02-12 12:08:32 UTC
*** Bug 1306949 has been marked as a duplicate of this bug. ***

Comment 5 Peter Robinson 2016-02-13 14:23:52 UTC
(In reply to Jan Synacek from comment #2)
> Possibly fixed by
> http://git.savannah.gnu.org/cgit/emacs.git/commit/
> ?id=0d6442265e5b709af5eebedf8f0d6b82974f4c31.

Not sure if the issue above is fixed but it breaks the build across all arches so in and of itself the issue of getting a build isn't fixed

http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3130470

Comment 6 Michel Normand 2016-02-15 07:28:08 UTC
(In reply to Michel Normand from comment #0)
> [CUT]
> ...
> I validate a set of patches in 
> http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3127419

To give easy access to the patches I embedded in related source rpm
and that allow to build emacs for ppc64le,
here is the list of patches I am attaching in next comments

Patch30:        emacs-24-0010-ELF-unexec-Correct-section-header-index.patch
Patch31:        emacs-24-0011-ELF-unexec-Tidy-code.patch
Patch32:        emacs-24-0012-ELF-unexec-Merge-Alpha-and-MIPS-COFF-debug-handling.patch
Patch33:        emacs-24-0013-ELF-unexec-Symbol-table-patching.patch
Patch34:        emacs-24-0014-ELF-unexec-_OBJC_-symbols-in-bss-sections.patch
Patch35:        emacs-24-0015-ELF-unexec-R_-_NONE-relocs.patch
Patch36:        emacs-24-0016-ELF-unexec-Drive-from-PT_LOAD-header-rather-than-sec.patch
Patch37:        emacs-24-0017-ELF-unexec-Don-t-insert-a-new-section.patch
Patch38:        emacs-24-0018-src-unexelf.c-NEW_PROGRAM_H-Remove-unused-macro-Bug-.patch
Patch39:        emacs-24-0019-ELF-unexec-align-section-header.patch

Comment 7 Michel Normand 2016-02-15 07:28:55 UTC
Created attachment 1127180 [details]
emacs-24-0010-ELF-unexec-Correct-section-header-index.patch

Comment 8 Michel Normand 2016-02-15 07:29:28 UTC
Created attachment 1127181 [details]
emacs-24-0011-ELF-unexec-Tidy-code.patch

Comment 9 Michel Normand 2016-02-15 07:30:00 UTC
Created attachment 1127182 [details]
emacs-24-0012-ELF-unexec-Merge-Alpha-and-MIPS-COFF-debug-handling.patch

Comment 10 Michel Normand 2016-02-15 07:30:30 UTC
Created attachment 1127183 [details]
emacs-24-0013-ELF-unexec-Symbol-table-patching.patch

Comment 11 Michel Normand 2016-02-15 07:31:06 UTC
Created attachment 1127184 [details]
emacs-24-0014-ELF-unexec-_OBJC_-symbols-in-bss-sections.patch

Comment 12 Michel Normand 2016-02-15 07:31:51 UTC
Created attachment 1127185 [details]
emacs-24-0015-ELF-unexec-R_-_NONE-relocs.patch

Comment 13 Michel Normand 2016-02-15 07:32:28 UTC
Created attachment 1127186 [details]
emacs-24-0016-ELF-unexec-Drive-from-PT_LOAD-header-rather-than-sec.patch

Comment 14 Michel Normand 2016-02-15 07:33:13 UTC
Created attachment 1127187 [details]
emacs-24-0017-ELF-unexec-Don-t-insert-a-new-section.patch

Comment 15 Michel Normand 2016-02-15 07:33:49 UTC
Created attachment 1127188 [details]
emacs-24-0018-src-unexelf.c-NEW_PROGRAM_H-Remove-unused-macro-Bug-.patch

Comment 16 Michel Normand 2016-02-15 07:34:27 UTC
Created attachment 1127189 [details]
emacs-24-0019-ELF-unexec-align-section-header.patch

Comment 17 Michel Normand 2016-02-15 07:37:07 UTC
Could we embed those patches in fedora DB ?

Comment 18 Jan Synacek 2016-02-15 09:16:06 UTC
Sorry, I didn't realize the original message actually contained another build with the patches... It was apparent from the build log.


Note You need to log in before you can comment on or make changes to this bug.