Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 130617 - gnome-sound-record Save and Save As commands fail silently
Summary: gnome-sound-record Save and Save As commands fail silently
Keywords:
Status: CLOSED DUPLICATE of bug 100774
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-22 20:39 UTC by Eric Smith
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:13 UTC


Attachments (Terms of Use)

Description Eric Smith 2004-08-22 20:39:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
gnome-sound-recorder is able to record, and the temporary file
containing the recording is visible in /tmp (e.g.,
/tmp/gsr-record-Untitled-12893.5EQjWV), but the Save and Save As
commands don't do anything.  The file the user selects via the file
chooser is not created, and gnome-sound-recorder still calls the
recording "Untitled".

This was reported by Phil Barnes in a comment on bug #100774, but is
almost certainly not related to the main bug reported there, thus I
have entered this as a separate bug.  Please do not close this as a
duplicate of 100774 without studying it.

Version-Release number of selected component (if applicable):
gnome-media-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1.  Open gnome-sound recorder
2.  Click the "record" button.
3.  Wait a bit
4.  Click the "stop" button.
5.  Click the "save as" button.
6.  Select a filename to save using the file chooser.

    

Actual Results:  No file created.  gnome-sound-record still calls the
recording "untitled".

Expected Results:  File user selected should be created.


Additional info:

Comment 1 Gerry Tool 2004-08-26 01:22:59 UTC
Same here, after installing gstreamer-0.8.5-1 from rawhide.

Comment 2 Eric Smith 2004-08-26 07:01:13 UTC
The machine on which I observed this behavior had a fairly plain
install of FC2.  It did have gstreamer-0.8.3-2 installed, but nothing
from rawhide.


Comment 3 Eric Smith 2004-08-26 08:50:59 UTC
In case it matters, my system is a dual Athlon 1900+ (Asus A7M266-D)
with 1.25GB of RAM and an Audigy Platinum sound card, running
kernel-2.6.7-1.494.2.2.


Comment 4 Colin Walters 2004-09-16 17:55:54 UTC

*** This bug has been marked as a duplicate of 100774 ***

Comment 5 Eric Smith 2004-09-16 18:21:42 UTC
Colin, thanks ever so much for carefully reading my comments then
deciding to close 130617 as a duplicate anyhow.  :-(

The problem Phil Barnes and I experienced is NOT the crash described
in 100774.  In our case, the recording works fine, but is not saved. 
No crash occurs.

Comment 6 Colin Walters 2004-09-16 18:29:58 UTC
Look, there are a ton of varied bugs against gnome-volume-control,
many of which overlap.  There are too many for me to track
individually.  I am going to make a decision soon about whether to
simply remove it entirely for FC3.

If we decide to ship it, we can reopen this one and start examining
and forwarding issues upstream individually.

Comment 7 Red Hat Bugzilla 2006-02-21 19:05:13 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.