Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1305259 - create installer API endpoints that will install Calamari-lite on Monitors
Summary: create installer API endpoints that will install Calamari-lite on Monitors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Gregory Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1316258
TreeView+ depends on / blocked
 
Reported: 2016-02-06 13:53 UTC by Gregory Meno
Modified: 2016-08-23 19:46 UTC (History)
12 users (show)

Fixed In Version: ceph-installer-1.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1316258 (view as bug list)
Environment:
Last Closed: 2016-08-23 19:46:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Gregory Meno 2016-02-06 13:53:47 UTC
Description of problem:

Calamari-lite runs on ceph Monitor nodes to provide a REST API for ceph

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Gregory Meno 2016-02-06 13:58:51 UTC
API is documented here https://github.com/ceph/mariner-installer/#calamari

Comment 4 Andrew Schoen 2016-02-08 16:58:14 UTC
Is this the same calamari that will handle registering nodes with USM during bootstrapping? I believe there was a requirement to have an agent installed on newly provisioned nodes that would register them with USM.

Comment 5 Gregory Meno 2016-02-09 20:32:26 UTC
*** Bug 1213082 has been marked as a duplicate of this bug. ***

Comment 6 Andrew Schoen 2016-02-09 21:41:38 UTC
I believe this is something we'll need to add to ceph-ansible. Are there docs somewhere for installing calamari-lite? Where will we get packages for calamari-lite? Do we need to configure calamari-lite in any way to get it to talk with USM?

Comment 7 Alfredo Deza 2016-02-11 16:16:25 UTC
Greg, in order to continue with this one we need a bit more of information.

"calamari-lite" (now known as the "agent") needs to be installed in the target nodes but:

* what are those packages named? both for Ubuntu and RHEL
* are the requirements for configuration the same as `ceph-deploy calamari connect` ? If so, the installer needs to know where is the master
* if the configuration for the agent is any different from `ceph-deploy calamari connect` we need to know what parts are so we can address them

Comment 8 Gregory Meno 2016-02-11 19:56:35 UTC
the rhscon-agent will be configured as calamari was in ceph-deploy
assume that the ceph-installer and USM will be hosted on the same FQDN for now

Comment 9 Alfredo Deza 2016-02-17 12:56:43 UTC
Pull Request that implements the API endpoint: https://github.com/ceph/ceph-installer/pull/42

Comment 10 Alfredo Deza 2016-03-09 20:24:53 UTC
Pull request in ceph-ansible that allows installing and initializing calamari-server on a monitor: https://github.com/ceph/ceph-ansible/pull/614

Comment 11 Mike McCune 2016-03-28 22:39:30 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 19 Martin Kudlej 2016-06-21 10:32:29 UTC
Checked with ceph-installer-1.0.11-1.el7scon.noarch and it works. Calamari runs only on one monitor. ->Verifed

Comment 21 errata-xmlrpc 2016-08-23 19:46:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.