Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1302758 - [freedv] Bundled sox does not have support for ppc64le
Summary: [freedv] Bundled sox does not have support for ppc64le
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: freedv
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2016-01-28 14:53 UTC by Rafael Fonseca
Modified: 2016-01-29 07:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-28 19:59:37 UTC


Attachments (Terms of Use)

Description Rafael Fonseca 2016-01-28 14:53:25 UTC
Description of problem: when building freedv on ppc64le it fails with the following error message

checking build system type... ./config.guess: unable to guess system type
This script, last modified 2009-11-20, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from
  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
and
  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD
If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.
config.guess timestamp = 2009-11-20
uname -m = ppc64le
uname -r = 4.2.6-301.fc23.ppc64le
uname -s = Linux
uname -v = #1 SMP Thu Nov 26 19:44:15 UTC 2015
/usr/bin/uname -p = ppc64le
/bin/uname -X     = 
hostinfo               = 
/bin/universe          = 
/usr/bin/arch -k       = 
/bin/arch              = ppc64le
/usr/bin/oslevel       = 
/usr/convex/getsysinfo = 
UNAME_MACHINE = ppc64le
UNAME_RELEASE = 4.2.6-301.fc23.ppc64le
UNAME_SYSTEM  = Linux
UNAME_VERSION = #1 SMP Thu Nov 26 19:44:15 UTC 2015
configure: error: cannot guess build type; you must specify one
CMakeFiles/sox.dir/build.make:110: recipe for target 'sox-prefix/src/sox-stamp/sox-configure' failed

That happens because the config.guess file only contains checks for ppc64, not for ppc64le. Adding

    ppc64le:Linux:*:*)
        echo powerpc64le-unknown-linux-gnu
        exit ;;

fixes the compilation.


Version-Release number of selected component (if applicable): 1.1-4


How reproducible: always on koji-ppc.


Additional info: Also fails on f23 and f22.

Comment 1 Richard Shaw 2016-01-28 15:24:18 UTC
My assumption is that this software being limited to ham radio operators, there would not be a large audience. Those running ppc64le would be even smaller which is why I excluded this arch. 

It's non-trivial to fix the bundled sox as it's built as an external project through cmake. Once upstream removes their dependence on a symbol made private in 14.4.2 I can drop the bundled sox and use the system version.

Comment 2 Dan Horák 2016-01-28 15:25:01 UTC
An option is to replace the old config.{guess,sub} from the system provided up-to-date copies in /usr/lib/rpm/redhat/ in %prep phase.

Comment 3 Richard Shaw 2016-01-28 15:28:46 UTC
Not quite that simple as the sox archive isn't even extracted at that time. I suppose the most direct method may be to create a patch and apply it in the cmake external project.

Comment 4 Richard Shaw 2016-01-28 15:40:05 UTC
Ok, more hackish but easy. Is the config.{guess,sub} recent enough in Fedora 22? I just extracted the source, overwrote the files, and rearchived it. I can upload it master.

Comment 5 Dan Horák 2016-01-28 15:47:47 UTC
it is, you can check with a scratch build with "ppc-koji build --scratch f24 freedv.src.rpm"

Comment 6 Richard Shaw 2016-01-28 16:25:00 UTC
Ok, that seemed to do the trick. I have a few things to do to make it offical though. I'll need to rename the archive so as not to confuse the lookaside cache but then rename it back to the correct file name in %prep.

I was only going to do a minor spec bump (after %dist) unless you need a full bump.

Comment 7 Richard Shaw 2016-01-28 19:59:37 UTC
Ok, good builds on rawhide and epel7 so I'm going to consider this resolved. Let me know if you need anything else.

Comment 8 Rafael Fonseca 2016-01-29 07:47:34 UTC
Thank you for the fix.


Note You need to log in before you can comment on or make changes to this bug.