Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 130 - German characters in file names cause tripwire to crash
Summary: German characters in file names cause tripwire to crash
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On: 1309435
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-19 13:30 UTC by dhunt
Modified: 2016-05-13 17:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-23 16:50:47 UTC


Attachments (Terms of Use)

Description dhunt 1998-11-19 13:30:57 UTC
In /usr/lib/linuxconf/images, there are several gif files
with German characters in them (they show up as \344 in
emacs).  When I attempt to secure my server by installing
tripwire, these file names cause it to crash.  This perhaps
should be called a bug in tripwire, but it seems that these
files could cause other applications problems as well.

Comment 1 Michael K. Johnson 1998-11-23 16:50:59 UTC
8-bit characters are intentionally allowed in filenames.
This is not a bug in Linuxconf, and as more and more files
with 8-bit names will show up, might as well fix tripwire
sooner as later.

Comment 2 openshift-github-bot 2016-05-13 17:12:10 UTC
Commit pushed to master at https://github.com/openshift/origin-aggregated-logging

https://github.com/openshift/origin-aggregated-logging/commit/e54cba43c75910430691e75fc2b55a6758c15c6c
Merge pull request #131 from ewolinetz/issue130

updating fluentd filter to not overwrite message field if it already exists


Note You need to log in before you can comment on or make changes to this bug.