Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 13 - mc vfs does not work with RPMs [solution included]
Summary: mc vfs does not work with RPMs [solution included]
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 5.2
Hardware: i386
OS: Linux
medium
unspecified
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 71 138 183 207 462 657 663 688 2997 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-09 18:28 UTC by stone
Modified: 2013-02-10 09:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-09 20:44:15 UTC


Attachments (Terms of Use)

Description stone 1998-11-09 18:28:12 UTC
Got this from the mc list:
change
    rpm -qlvp $1 | sed -e 's/^\(..........\)[-t] /\1 1 /'
to
    rpm -qlvp $1 | sed -e 's/^\(..........\)/\1 1 /'

in /usr/lib/mc/extfs/rpm

solves the problem.

Comment 1 Bill Nottingham 1998-11-16 15:15:59 UTC
*** Bug 71 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 1998-11-16 15:20:59 UTC
Will be fixed in next release. As a workaround, you can update
to mc 4.1.36, which includes this fix.

Comment 3 Bill Nottingham 1998-11-20 11:33:59 UTC
*** Bug 138 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 1998-11-24 15:49:59 UTC
*** Bug 183 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 1998-11-30 15:54:59 UTC
*** Bug 207 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 1998-12-15 21:38:59 UTC
*** Bug 13 has been marked as a duplicate of this bug. ***
mc                      Make rpmfs working for rpm 2.5+.

Comment 7 David Lawrence 1998-12-30 18:34:59 UTC
*** Bug 13 has been marked as a duplicate of this bug. ***

Something broke mc's coolest feature (according to the
package description) i.e. the ability to peek into rpm
files. When you cd into an rpm file on RedHat Linux 5.2 you
cannot see the files in it only HEADER, INSTALL, UPGRADE and
INFO. It used to work on older versions of RedHat Linux
(5.1, 5.0) with the same mc version (4.1.35).

The line that doesn't work any more in /usr/lib/mc/extfs/rpm
looks like:

rpm -qlvp $1 | sed -e 's/^\(..........\)[-t] /\1 1 /'

Removing [-t] from the above line corrects the problem, but
the same line used to work in earlier versions so the bug is
somwhere else. Maybe the output of rpm has changed (seems
not to be the case), or maybe sed has changed (this can be
the real reason, but I'm not sure).

Comment 8 Jeff Johnson 1999-01-01 21:22:59 UTC
*** Bug 13 has been marked as a duplicate of this bug. ***

On the mc that ships with RH 5.2 for i386 when one presses
enter on an rpm the contents of the RPM are not properly
shown. Only the ../, /INFO, HEADER, INSTALL and UPGRADE
files show up. None of the actual files installed by the rpm
show up.

	I have actually fixed this bug by editing the file
/usr/lib/mc/extfs/rpm as folows

# diff /usr/lib/mc/extfs/rpm /usr/lib/mc/extfs/rpm~
100c100
<     rpm -qlvp $1 | sed -e 's/^\(..........\)/\1 1 /'
---
>     rpm -qlvp $1 | sed -e 's/^\(..........\)[-t] /\1 1 /'
#

It now works properly.  I do not know whether I should send
this fix as a patch to bugzilla.  Would appreciate any
advice.

prabhu

Comment 9 Jeff Johnson 1999-01-05 15:52:59 UTC
*** Bug 13 has been marked as a duplicate of this bug. ***

all you get when you enter an rpm package with mc's vfs is
the header list.
apply this patch to fix:
-cut-cut-
--- rpm.orig	Wed Dec 30 23:58:00 1998
+++ rpm	Fri
Jan  1 12:46:34 1999
@@ -5,6 +5,7 @@
 #            Tomasz
K&oczko (kloczek@rudy.mif.pg.gda.pl) 1997
 # minor changes
by Wojtek Pilorz (wpilorz@bdk.lublin.pl) 1997
 # minor
changes by Michele Marziani (marziani@fe.infn.it) 1997
+#
fix to handle new rpm output by Andrea Borgia
<borgia@students.cs.unibo.it> (1999)
 # (C) 1996 The Free
Software Foundation.
 #
 #
@@ -97,7 +98,7 @@
         echo
"$FILEPREF 0 $DATE INFO/CHANGELOG"
     fi

-    rpm -qlvp
$1 | sed -e 's/^\(..........\)[-t] /\1 1 /'
+    rpm -qlvp
$1 | sed -e 's/^\(..........\) /\1 1 /'
 }


mcrpmfs_copyout ()
-cut-cut-

Comment 10 Jeff Johnson 1999-06-03 14:38:59 UTC
*** Bug 2997 has been marked as a duplicate of this bug. ***

mc doesnot show contents of rpm exept /INFO, INSTALL and UPGRADE
file: /usr/lib/mc/extfs/rpm, line 100:
rpm -qlvp $1 | sed -e 's/^\(..........\)[-t] /\1 1 /'
replace with:
rpm -qlvp $1 | sed -e 's/^\(..........\) /\1 1 /'

------- Additional Comments From johnsonm@redhat.com  05/25/99 14:46 -------
What version of rpm do you have installed?


Note You need to log in before you can comment on or make changes to this bug.