Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1299800 - dracut multipath module can't find devices without user_friendly_names turned on
Summary: dracut multipath module can't find devices without user_friendly_names turned on
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: dracut-maint
QA Contact: Release Test Team
URL:
Whiteboard:
: 1360326 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-19 09:54 UTC by Pekka Wallendahl
Modified: 2018-09-27 13:34 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 08:02:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3628111 None None None 2018-09-27 13:34:21 UTC
Red Hat Product Errata RHBA-2016:2530 normal SHIPPED_LIVE dracut bug fix and enhancement update 2016-11-03 14:17:01 UTC

Description Pekka Wallendahl 2016-01-19 09:54:37 UTC
Description of problem:


Version-Release number of selected component (if applicable):
dracut-033-360.el7_2.x86_64

How reproducible:
Always

Steps to Reproduce:

1. You need multipathed devices, in my cases FibreChannel LUNs 

2. In /etc/multipath.conf set following:
defaults {
    user_friendly_names  no
}

Alternatively you can set aliases for your wwids.

3. Reboot

4. Now multipathed devices appear as symlinks like /dev/mapper/360a0123456789abcdef0123456789abcde -> --/dev/dm-X

5. Run: `dracut /tmp/test.img` which gives one to many error msgs:
ls: cannot access /dev/mapper/mpath*: No such file or directory

Actual results:
Dracut skips all those devices that do not have mpath-prefixes.

Expected results:
Dracut should iterate over all devices in /dev/mapper and determine if they are multipath devices by using other means (such as checking their uuid under /sys)

Additional info:
This bug has been fixed in upstream with following commit: https://github.com/haraldh/dracut/commit/918fbfcf6b99016f1d426e7c131b9fdeaaaede89

Comment 3 Mike McCune 2016-03-28 22:31:02 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 5 Michal Kovarik 2016-08-03 11:12:48 UTC
Reproduced on RHEL-7.2 with dracut-033-359.el7. Verified with dracut-033-450.el7. Patch is included, no error messages when running dracut.

Comment 6 Harald Hoyer 2016-08-10 12:24:10 UTC
*** Bug 1360326 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2016-11-04 08:02:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2530.html


Note You need to log in before you can comment on or make changes to this bug.